Dividing(多重背包01背包)

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line “1 0 1 2 0 0”. The maximum total number of marbles will be 20000.

The last line of the input file will be “0 0 0 0 0 0”; do not process this line.

Output

For each collection, output “Collection #k:”, where k is the number of the test case, and then either “Can be divided.” or “Can’t be divided.”.

Output a blank line after each test case.

Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output
Collection #1:
Can’t be divided.

Collection #2:
Can be divided.
题意:一共有6种物品,价值分别是1,2,3,4,5,6,给出每种物品的数目,判断价值是否能够平分
(看做价值与体积相等的物品)
思路:多重背包 二进制优化 转01背包

#include<cstdio> 
#include<algorithm>
#include<cstring>
using namespace std;
int a[7];
int dp[60005];
int w[60005],v[60005];
int main(){
	int Case=0;
	while(true){
		int sumval=0;//总价值初始化 
		for(int i=1;i<=6;i++){
			scanf("%d",&a[i]);
			sumval+=a[i]*i;
		}
		if(sumval==0) break;//即全为0,跳出循环,结束
		if(sumval&1){ //总价值为奇数,肯定无法平分 
			printf("Collection #%d:\nCan't be divided.\n\n",++Case) ;
			continue;
		} 
		else
		{
			int W=sumval>>1;
			for(int i=1;i<=W;i++)
			dp[i]=0;
			int cnt=1;
			for(int i=1;i<=6;i++){         //二进制优化 
				for(int j=1;j<=a[i];j<<=1){
					v[cnt]=j*i;
					w[cnt]=j*i;
					cnt++;
					a[i]-=j;
				}
				if(a[i]>0){
					v[cnt]=a[i]*i;
					w[cnt]=a[i]*i;
					cnt++;
				}
			}
			for(int i=1;i<cnt;i++){
				for(int j=W;j>=w[i];j--){
					dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
				}
			} 
			if(dp[W]==W)
			printf("Collection #%d:\nCan be divided.\n\n",++Case); 
			else
			printf("Collection #%d:\nCan't be divided.\n\n",++Case) ;			
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值