Dining (拆点 EK模板)

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input
Line 1: Three space-separated integers:  NF, and  D 
Lines 2..  N+1: Each line  i starts with a two integers  Fi and  Di, the number of dishes that cow  i likes and the number of drinks that cow  i likes. The next  Fiintegers denote the dishes that cow  i will eat, and the  Di integers following that denote the drinks that cow  i will drink.
Output
Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes
Sample Input
4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3
Sample Output
3
Hint
One way to satisfy three cows is: 
Cow 1: no meal 
Cow 2: Food #2, Drink #2 
Cow 3: Food #1, Drink #1 
Cow 4: Food #3, Drink #3 
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.


题意:每个牛都只吃自己想要吃的食物和饮料,有N头牛,F种食物,D种饮料;接下来2~N+1行每行开始有两个数Fi,Di,分别代表没头牛喜欢的食物和饮料的个数,接下来有

Fi+Di个数,表示每个牛喜欢的食物饮料的种类;


拆点,将牛拆成2个A和A',中间连一条弧,容量为1,源点->食物->牛A->牛A'->饮料->汇点;套用EK模板~


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<map>
#include<vector>
#include<queue>
#include<string>
using namespace std;
const int MAXN=500+10;
const int inf=0x3f3f3f;
int mp[MAXN][MAXN];
int n,F,D,N;
int vast[MAXN],pre[MAXN];
int Ek()
{
    queue<int>s;
    int ans=0;
    while(1)
    {
        memset(vast,0,sizeof(vast));
        memset(pre,-1,sizeof(pre));
        while(!s.empty())
            s.pop();
        vast[0]=1;
        s.push(0);
        while(!s.empty())
        {
            int now=s.front();
            s.pop();
            if(now==N+1)
                break;
            for(int i=0;i<=N+1;i++)
            {
                if(!vast[i]&&mp[now][i]>0)
                {
                    vast[i]=1;
                    pre[i]=now;
                    s.push(i);
                }
            }
        }
        if(!vast[N+1])
            break;
        int minn=inf;
        for(int i=N+1;i!=0;i=pre[i])
        {
            minn=min(minn,mp[pre[i]][i]);
        }
        ans+=minn;
        for(int i=N+1;i!=0;i=pre[i])
        {
            mp[pre[i]][i]-=minn;
            mp[i][pre[i]]+=minn;
        }
    }
    return ans;
}
int main()
{
    while(~scanf("%d%d%d",&n,&F,&D))
    {
        N=2*n+F+D;
        memset(mp,0,sizeof(mp));
        int food,drink,f,d;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&food,&drink);
            for(int j=1;j<=food;j++)
            {
                scanf("%d",&f);
                mp[0][2*n+f]=1;
                mp[2*n+f][i]=1;
                mp[i][n+i]=1;
            }
            for(int j=1;j<=drink;j++)
            {
                scanf("%d",&d);
                mp[n+i][2*n+F+d]=1;
                mp[2*n+F+d][N+1]=1;
            }
        }
        int flow=Ek();
        printf("%d\n",flow);
    }
}












  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值