POJ3281 Dining 求最大流

Dining
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11501 Accepted: 5277

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers:  NF, and  D 
Lines 2.. N+1: Each line  i starts with a two integers  Fi and  Di, the number of dishes that cow  i likes and the number of drinks that cow  i likes. The next  Fi integers denote the dishes that cow i will eat, and the  Di integers following that denote the drinks that cow  i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint

One way to satisfy three cows is: 
Cow 1: no meal 
Cow 2: Food #2, Drink #2 
Cow 3: Food #1, Drink #1 
Cow 4: Food #3, Drink #3 
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

题意:告诉n头奶牛,f 种食物, d种饮料,然后告诉每头奶牛吃饭时喜欢吃的食物编号和饮料编号,每种食物和饮料都只有一份,每头奶牛也只吃一份食物和饮料,求最多能满足几头奶牛的需要。

分析:求最大流,告诉了食物和饮料两个影响成分,并且还要满足一头牛只吃一份食物和饮料,一种食物和饮料都只有一份。这个地方把每头奶牛扩展成两个点,这样就能够保证对于每头奶牛可以同时满足只吃一份食物和饮料。最大流,用EK来解决


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#define N 2222
#define INF 9999999
using namespace std;

int n,f,d;
int cap[N][N];
int pre[N];
int a[N];
int flow[N][N];
int s,t;

void EK()
{
    memset(flow,0,sizeof flow);
    int ans=0;
    while(1)
    {
        queue<int>q;
        q.push(s);
        memset(a,0,sizeof a);
        memset(pre,-1,sizeof pre);
        a[s]=INF;
        while(!q.empty())
        {
            int v=q.front();q.pop();
            if(v==t) break;

            for(int i=s;i<=t;i++)
            {
                if(pre[i]<0 && cap[v][i]-flow[v][i]>0)
                {
                    pre[i]=v;
                    q.push(i);
                    a[i]=min(a[v],cap[v][i]-flow[v][i]);
                }
            }
        }
        if(pre[t]<0) break;

        for(int i=t;i!=s;i=pre[i])
        {
            int j=pre[i];
            flow[i][j]-=a[t];
            flow[j][i]+=a[t];
        }
        ans+=a[t];
    }
    printf("%d\n",ans);
}

int main()
{
    while(~scanf("%d%d%d",&n,&f,&d))
    {
        memset(cap,0,sizeof cap);
        s=0;t=n*2+f+d+1;

        for(int i=1;i<=f;i++) cap[s][i]=1; //让食物和源点相连
        for(int i=2*n+f+1;i<=n*2+f+d;i++) cap[i][t]=1;//让饮料和汇点相连
        for(int i=f+1;i<=f+n;i++) cap[i][i+n]=1;//牛与牛之间相互连接

        for(int i=1;i<=n;i++)
        {
            int a,b,k;
            scanf("%d%d",&a,&b);
            for(int j=0;j<a;j++)
            {
                scanf("%d",&k);
                cap[k][i+f]=1;
            }
            for(int j=0;j<b;j++)
            {
                scanf("%d",&k);
                cap[i+n+f][k+f+2*n]=1;
            }
        }

        EK();
    }
    return 0;
}







  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值