Dating with girls(2)

题目:

If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity! 
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there. 
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down. 

Input

The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10). 
The next r line is the map’s description.

Output

For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".

Sample Input

1
6 6 2
...Y..
...#..
.#....
...#..
...#..
..#G#.

Sample Output

7

 

题意:

你要找一个女孩约会,路上有石头,如果你到石头的时间刚好是K的倍数,石头就会消失,你就可以到这个位置。

问你能不能和女孩约会,如果能最短时间是多少,如果不能输出"Please give me another chance!"。

 

思路:

搜索题,注意标记的时候用三维标记,其中一维表示的是到这个位置的时间除于K的余数;

 

代码:

#include<stdio.h>
#include<queue>
#include<algorithm>
#include<string.h>
using namespace std;
int n,m,k;
int book[15][150][150],dis[4][2]={1,0,-1,0,0,1,0,-1};
char mp[150][150];
struct node
{
    int x,y,s;
};
int bfs(int x,int y)
{
    queue<node>q;
    struct node now,next;
    now.x=x;
    now.y=y;
    now.s=0;
    q.push(now);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            int tx=now.x+dis[i][0];
            int ty=now.y+dis[i][1];
            if(tx>=0&&ty>=0&&tx<n&&ty<m)
            {
                if((mp[tx][ty]=='.'||mp[tx][ty]=='Y')&&book[(now.s+1)%k][tx][ty]==0)
                {
                    book[(now.s+1)%k][tx][ty]=1;
                    next.x=tx;
                    next.y=ty;
                    next.s=now.s+1;
                    q.push(next);
                }
                else if((now.s+1)%k==0&&mp[tx][ty]=='#'&&book[(now.s+1)%k][tx][ty]==0)
                {
                    book[(now.s+1)%k][tx][ty]=1;
                    next.x=tx;
                    next.y=ty;
                    next.s=now.s+1;
                    q.push(next);
                }
                if(mp[tx][ty]=='G')
                {
                    return now.s+1;
                }
            }
        }
    }
    return -1;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(book,0,sizeof(book));
        scanf("%d%d%d",&n,&m,&k);
        for(int i=0;i<n;i++)
            scanf("%s",mp[i]);
        int flag=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(mp[i][j]=='Y')
                {
                    book[0][i][j]=1;
                    int f=bfs(i,j);
                    if(f!=-1)
                        printf("%d\n",f);
                    else
                        printf("Please give me another chance!\n");
                    flag=1;
                    break;
                }
            }
            if(flag)
                break;
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值