a1039 Course List for Student (map)

1039 Course List for Student (25 分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni​ (≤200) are given in a line. Then in the next line, Ni​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

 题意:给出每门课有哪些人选了,然后最后给出一堆要查询自己选了哪些课的学生,依次输入这些学生所选的课以及所选课程数量。

思路:用map把名字和数字相互转化,然后每个学生建立一个vector,储存所选的课程。课程号,因为是按照先后出现顺序排列的,按照题意需要按照从小到大输出,所以再进行sort排序就好了。

反思:刚开始看到就想到了用map,但是最后一个测试点一直提示段错误,看了半天,也不知道哪里错了,最后看别人代码,原来是学生总数设置错了。题上写的查询人数小于40000,但实际人数应该是小于26*26*26*10(四位,前三位是字母,26种选择,最后一位数字,10种选择),然后把总数设置成200000,就通过了。

#include <iostream>
#include "vector"
#include "map"
#include "algorithm"
using namespace std;
int index=0;
map<string,int> stringtoint;
map<int,string> inttostring;
vector<int> stu[200000];
int change(string na){
    if (stringtoint.find(na) == stringtoint.end()){
        index++;
        stringtoint[na]=index;
        inttostring[index] = na;
        return index;
    } else{
        return stringtoint[na];
    }
}
int main() {
    int n,k;
    scanf("%d%d",&n,&k);
    int courseid,num;
    string name;
    for (int i = 0; i < k; ++i) {
        scanf("%d%d\n",&courseid,&num);
        for (int j = 0; j < num; ++j) {
            cin>>name;
            int a = change(name);
            stu[a].push_back(courseid);
        }
    }
    for (int i = 1; i <= n; ++i) {
        cin>>name;
        cout<<name;
        int t = stringtoint[name];
        int len = stu[t].size();
        sort(stu[t].begin(),stu[t].end());
        cout<<" "<<len;
        for (int j = 0; j < len; ++j) {
            cout<<" "<<stu[t][j];
        }
        printf("\n");
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值