A1039 Course List for Student

  1. 题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (≤200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
  1. 问题分析

  • 给选某一门课i 对应的学生 名称,需要根据学生名称去反过来查询选了什么课

  • 输入 i:vector<string> 这是一个map映射

  • 然后去遍历每一个i中的名字,拿着要查询的名字去找 find(value),若是找到了,那么

  • 名字:vector<int> 来一个映射


上面的思路是正常的思路,符合正常的查询流程,但是算法题往往需要输入,我们可以在输入的过程中,就进行算法

  • 在输入过程中,对每一个名字建立一个 名字:vector<int> 映射 然后int 是本课程的index


但是map非常占用时间和空间,即使用unordermap也不行

可以使用字符串hash

对学生编号进行计算映射到数组下标中

  1. 代码编写

#include <iostream>
#include <vector>
#include <string>
#include <map>
#include <algorithm>
#include <unordered_map>
using namespace std;
int main() {
    int stuN,claK;
    scanf("%d %d",&stuN,&claK);
    
    unordered_map<string,vector<int> > mp;
    int claindex,clastu;
    string name;
    for(int i=0;i<claK;i++)
    {
        scanf("%d %d",&claindex,&clastu);
        for(int j=0;j<clastu;j++)
        {
            cin>>name;
            mp[name].push_back(claindex);
        }
    }
//    for(auto it:mp)
//    {
//        cout<<it.first<<" ";
//    }
    for(int i=0;i<stuN;i++)
    {
        cin>>name;
        if(mp.find(name)!=mp.end())
        {
            sort(mp[name].begin(),mp[name].end());
            cout<<name<<" "<<mp[name].size()<<" ";
            for(int j=0;j<mp[name].size()-1;j++)
            {
                cout<<mp[name][j]<<" ";
            }
            cout<<mp[name][mp[name].size()-1]<<endl; ;
        } else{
            cout<<name<<" "<<0<<endl;
        }

    }
    return 0;
}

3.1更加快速的代码

#include <iostream>
#include <vector>
#include <string>
#include <map>
#include <algorithm>
#include <unordered_map>
using namespace std;

const int maxn = 26 * 26 * 26 * 10 + 10;
vector<int> v[maxn];

int hashStr(string name)
{
    int index=0;
    index+= (name[0]-'A' )*10*26*26;
    index+= (name[1]-'A' )*10*26;
    index+= (name[2]-'A' )*10;
    index+= (name[3]-'0' );
    return index;
}



int main() {
    int stuN,claK;
    scanf("%d %d",&stuN,&claK);

    int index;
    int claindex,clastu;
    string name;

    for(int i=0;i<claK;i++)
    {
        scanf("%d %d",&claindex,&clastu);
        for(int j=0;j<clastu;j++)
        {
            cin>>name;
            index= hashStr(name);
            v[index].push_back(claindex);
        }
    }
//    for(auto it:mp)
//    {
//        cout<<it.first<<" ";
//    }
    for(int i=0;i<stuN;i++)
    {
        cin>>name;
        index = hashStr(name);

        sort(v[index].begin(),v[index].end());
        cout<<name<<" "<<v[index].size();
        for(int j=0;j<v[index].size();j++)
        {
            cout<<" "<<v[index][j];
        }
        cout<<endl;
    }
 
    return 0;
}
  1. 收获与思考

  • 重大BUG:对于j<v.size-1要慎用,因为对于size为0来说,这个东西就不能用

  • 如果出现map<string,int>超时的现象,可以使用字符串hash

  • 但是算法题往往需要输入,我们可以在输入的过程中,就进行算法

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值