1113 Integer Set Partition (sort排序)

1113 Integer Set Partition (25 分)

Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A1​ and A2​ of n1​ and n2​ numbers, respectively. Let S1​ and S2​ denote the sums of all the numbers in A1​ and A2​, respectively. You are supposed to make the partition so that ∣n1​−n2​∣ is minimized first, and then ∣S1​−S2​∣ is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤105), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 231.

Output Specification:

For each case, print in a line two numbers: ∣n1​−n2​∣ and ∣S1​−S2​∣, separated by exactly one space.

Sample Input 1:

<span style="color:#404040"><span style="background-color:#ffffff"><code class="language-in">10
23 8 10 99 46 2333 46 1 666 555
</code></span></span>

Sample Output 1:

<span style="color:#404040"><span style="background-color:#ffffff"><code class="language-out">0 3611
</code></span></span>

Sample Input 2:

<span style="color:#404040"><span style="background-color:#ffffff"><code class="language-in">13
110 79 218 69 3721 100 29 135 2 6 13 5188 85
</code></span></span>

Sample Output 2:

<span style="color:#404040"><span style="background-color:#ffffff"><code class="language-out">1 9359</code></span></span>

题意:给定一系列数,把这些数分成两个不相交的集合s1,s2;要求s1,s2长度差的绝对值最小, 数列和的差的绝对值最大。

思路:直接把输入的数组排序,那么s1就是前n/2个,s2就是剩下的,然后分别算和就好了。

#include <iostream>
#include "algorithm"
using namespace std;
long long int nums[100100];
int main() {
    int n;
    cin>>n;
    for (int i = 0; i < n; ++i) {
        cin>>nums[i];
    }
    int len1,len2,sum1=0,sum2=0;
    if (n%2==0) len1=len2=n/2;
    else len1=n/2+1,len2=n/2;
    sort(nums,nums+n);
    for (int i = 0; i < len2; ++i) {
        sum2 += nums[i];
    }
    for (int i = len2; i <len2+len1 ; ++i) {
        sum1 +=nums[i];
    }
    cout<<len1-len2<<" "<<sum1-sum2;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值