I - All in All

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input Specification

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output Specification

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No




哭瞎。。看起来这么简单的一道题。。。暗藏了好多坑。。(不过应该还是我技术太差。。)首先,题目里没有给字符串的数据范围,因为这个RE了两次(〒_〒),以后做这种没给范围的题一定要把数组往大开。其次就是自己在考虑问题的时候想得太简单,只是单纯的样例对了就提交,没有深入思考其他一些特殊的情况,因为这个WA了两次(〒_〒)(ps:估计自己的算法太差,,所以才需要考虑很多种情况)。



#include <stdio.h>
#include <string.h>

char str1[1000000],str2[1000000];
int main()
{
    int i,j,flag;
    while(~scanf("%s %s",str1,str2))
    {
        j=0;
        flag=0;
        for(i=0;i<strlen(str1);i++)
        {
            for(;j<strlen(str2);j++)
            {
                if(str1[i]==str2[j])
                {
                    if(i==strlen(str1)-1)
                        flag=1;
                    break;
                }
            }
            j++;
        }
        if(flag==1) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/Highmath/p/4174819.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值