PAT_A1060 Are They Equal【困难】

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3
#include<bits/stdc++.h>  
using namespace std;  
int n;  
bool myfind(char a){  
    if('0' < a &&  a <= '9') return true;  
    else return false;  
}  
string conver(string s){  
    int t = s.find(".");  
    // 小数点的位置  
    int l = t==string::npos ? s.size(): t;  
    // 第一个非零元素的位置  
    int p = find_if(s.begin(), s.end(), myfind) - s.begin();  
//    p = p == s.size() ? l + 1 : p;  
    if (p == s.size()){  
        string r = "0.";  
        int c = n;  
        while (c--){  
            r += "0";  
        }  
        return r += "*10^0";  
    }  
    string t2 = s;  
    string front = t2.erase(l, 1).substr(p < l ? p : p-1, n);  
    string r = "0.";  
    r+=front;  
    if(p+n > s.size()){  
        int c = p+n-s.size();  
        while(c--) r+="0";  
    }  
    int k = l-p < 0 ? l-p+1 : l-p;  
    r+="*10^" + to_string(k);  
    return r;  
}  
int main(){  
    string a, b;  
    cin>>n>>a>>b;  
    a = conver(a);  
    b = conver(b);  
    a == b ? cout<<"YES "<<a<<endl : cout<<"NO "<<a<<" "<<b<<endl; 
    return 0;  
}

总结:
测试点6卡了很久,最后加了特判if (p == s.size()) 才通过,应该是后面的元素位置、开闭区间的计算有问题。
测试点6

4  
0.00  
0  
(答案为:0.0000*10^0)
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值