HDU - 1702 - ACboy needs your help again!

ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(. 
 As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy." 
The problems of the monster is shown on the wall: 
 Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out"). 
and the following N lines, each line is "IN M" or "OUT", (M represent a integer). 
 and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
InputThe input contains multiple test cases. 
The first line has one integer,represent the number oftest cases. 
And the input of each subproblem are described above.OutputFor each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT
Sample Output
1
2
2
1
1
2
None
2

3

这道题就是理解栈和队列的异同 栈是先进后出FILO 队是先进先出FIFO

队或栈 都为空时输出None

#include<stdio.h>  
#include<string.h>  
int main()  
{  
    int t,n,i,j,num,a[10000];  
    char str[10],mark[10];  
    scanf("%d",&t);  
    while(t--)  
    {  
        scanf("%d%s",&n,str);  
        if(strcmp(str,"FIFO")==0)//队列   
        {  
            i=j=0;//i为进队列数,j为出队列数   
            while(n--)  
            {  
                scanf("%s",mark);  
                if(strcmp(mark,"IN")==0)  
                {  
                    scanf("%d",&num);  
                    a[i++]=num;//进队列   
                }  
                else  
                {  
                    if(j>=i)//判断队列是否为空   
                       printf("None\n");  
                    else  
                       printf("%d\n",a[j++]);//出队列   
                }  
            }  
        }  
        else if(strcmp(str,"FILO")==0)//栈   
        {  
            i=0;  
            while(n--)  
            {  
                scanf("%s",mark);  
                if(strcmp(mark,"IN")==0)  
                {  
                    scanf("%d",&num);  
                    a[i++]=num;//进栈,注意此处i值在a[i]赋值后自增1,即此处后a[i]是没有被赋值的   
                }  
                else  
                {  
                    if(i<1)//若a[0]已经被赋值,i必等于1   
                       printf("None\n");  
                    else  
                       printf("%d\n",a[--i]);//出栈,先自减再经行运算   
                }  
            }  
        }  
    }  
    return 0;  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值