HDOJ -- 1260 Tickets

Tickets
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 

Sample Input

2
2
20 25
40
1
8

Sample Output

08:00:40 am
08:00:08 am

题目大意:总共有N个人,给出每个人单独买票的时间,以及相邻两人一起买票的时间,求出N个人买完票后所用时间的最小值。
简单DP,注意下输出格式就行了。用数组one[i]表示第i个人单独买票所用的时间;用数组two[i]表示第i个人和第i-1个人一起买票所用的时间;再用数组dp[i]记录前i个人买完票后所用的最少时间。那么就可以写出其状态转移方程:dp[i]=min(dp[i-1]+one[i],dp[i-2],two[i])。代码如下:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main(){
	int dp[10005];
	int one[60005],two[60005];
	int N,k;
	int h,m,s;
	char a[5]={'a','m'};
	scanf("%d",&N);
	while(N--){
		scanf("%d",&k);
		for(int i=1;i<=k;i++)
			scanf("%d",&one[i]);
		for(int i=2;i<=k;i++)//i从2开始!! 
			scanf("%d",&two[i]);
		memset(dp,0,sizeof(dp));
		dp[1]=one[1];
		for(int i=2;i<=k;i++)
			dp[i]=min(dp[i-1]+one[i],dp[i-2]+two[i]);
		h=8+dp[k]/3600;//时 
		m=dp[k]%3600/60;//分 
		s=(dp[k]%3600)%60;//秒 
		if(h>=12){
			if(h>12)
				h-=12;
			a[0]='p';
		}
		printf("%02d:%02d:%02d %s\n",h,m,s,a);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值