hdoj1260Tickets

Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
 

Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
 

Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
 

Sample Input
  
  
2 2 20 25 40 1 8
 

Sample Output
  
  
08:00:40 am 08:00:08 am

问有n个人去看电影,要么一人一次买一张,要么相邻的两个人一起买两张,现在给出n个人的买票时间和n-1个相邻两个人一起买票的时间.

求最早什么时候能卖完票,从早上八点开始.

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[2020],one[2020],two[2020];
int main()
{
	int i,n,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);//dp[n]表示n个人买票的时间 
		memset(dp,0,sizeof(dp));
		for(i=1;i<=n;i++)
		scanf("%d",&one[i]);//存一个人买票的时间 
		for(i=2;i<=n;i++)
		scanf("%d",&two[i]);//存相邻两个人一起买票的时间 two[i]记录的是第i个人和第i-1个人一起买票的时间 
		dp[1]=one[1];//初始化 
		for(i=2;i<=n;i++)
		dp[i]=min(dp[i-1]+one[i],dp[i-2]+two[i]);
		int t=28800+dp[n];//8个小时等于28800秒,再加上买票所需要的时间,即为卖票结束的时间 
		int h=t/3600;
		int m=t%3600/60;
		int s=t%3600%60;
		if(h>=12)
		{
			h-=12;
			printf("%02d:%02d:%02d pm\n",h,m,s);
		}
		else
		printf("%02d:%02d:%02d am\n",h,m,s);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值