poj 2777 Count Color

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. 

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board: 

1. "C A B C" Color the board from segment A to segment B with color C. 
2. "P A B" Output the number of different colors painted between segment A and segment B (including). 

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your. 

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

一道简单的线段树区间更新,区间查询的题目,当然是要用mark标记,网上好多人说这是laxy标记,其实这不是lazy,而是更好的方法,主要是30种颜色怎么表示,当然好表示了,2的30次放也是整形数据嘛,用集合的交并就可以了
#include<map>
#include<set>
#include<queue>
#include<cmath>
#include<vector>
#include<cstdio>
#include<string>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#define  inf 0x0f0f0f0f

using namespace std;
const int maxn=100000+10;

struct node
{
     int left,right,sum,mark;
}tree[maxn*8];

int get_sum(int s)
{
     int ans=0;
     while(s)
     {
          if (s%2) ans++;
          s=s/2;
     }
     return ans;
}

void build(int c,int x,int y)
{
     tree[c].left=x; tree[c].right=y; tree[c].sum=1; tree[c].mark=0;
     if (x==y) return;
     int mid=x+(y-x)/2;
     build(c*2,x,mid);
     build(c*2+1,mid+1,y);
}

void update(int c,int x,int y,int v)
{
     if (tree[c].left==x && tree[c].right==y)
     {
          tree[c].sum=1<<v;
          tree[c].mark=v+1;
          return;
     }
     if (tree[c].mark)
     {
          tree[c*2].sum=1<<(tree[c].mark-1);
          tree[c*2].mark=tree[c].mark;
          tree[c*2+1].sum=1<<(tree[c].mark-1);
          tree[c*2+1].mark=tree[c].mark;
          tree[c].mark=0;
     }
     int mid=tree[c].left+(tree[c].right-tree[c].left)/2;
     if (y<=mid) update(c*2,x,y,v);
     else if (x>mid) update(c*2+1,x,y,v);
     else
     {
          update(c*2,x,mid,v);
          update(c*2+1,mid+1,y,v);
     }
     tree[c].sum=tree[c*2].sum | tree[c*2+1].sum;
}

int reseach(int c,int x,int y)
{
     if (tree[c].left==x && tree[c].right==y)
     return tree[c].sum;
     if (tree[c].mark)
     {
          tree[c*2].sum=1<<(tree[c].mark-1);
          tree[c*2].mark=tree[c].mark;
          tree[c*2+1].sum=1<<(tree[c].mark-1);
          tree[c*2+1].mark=tree[c].mark;
          tree[c].mark=0;
     }
     int mid=tree[c].left+(tree[c].right-tree[c].left)/2;
     if (y<=mid) return reseach(c*2,x,y);
     else if (x>mid) return reseach(c*2+1,x,y);
     else
     {
          return (reseach(c*2,x,mid) | reseach(c*2+1,mid+1,y));
     }
}

int main()
{
     int n,t,m,x,y,v;
     char str[3];
     while(scanf("%d%d%d",&n,&t,&m)!=EOF)
     {
          build(1,1,n);
          while(m--)
          {
               scanf("%s",str);
               if (str[0]=='C')
               {
                    scanf("%d%d%d",&x,&y,&v);
                    if (x>=y) swap(x,y);
                    update(1,x,y,v-1);
               }
               else
               {
                    scanf("%d%d",&x,&y);
                    if (x>=y) swap(x,y);
                    int temp=reseach(1,x,y);
                    int ans=get_sum(temp);
                    printf("%d\n",ans);
               }
          }
     }
     return 0;
}

作者 chensunrise

转载于:https://www.cnblogs.com/chensunrise/p/3799153.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值