Subway

You have just moved from a quiet Waterloo neighbourhood to a big, noisy city. Instead of getting to ride your bike to school every day, you now get to walk and take the subway. Because you don't want to be late for class, you want to know how long it will take you to get to school.
You walk at a speed of 10 km/h. The subway travels at 40 km/h. Assume that you are lucky, and whenever you arrive at a subway station, a train is there that you can board immediately. You may get on and off the subway any number of times, and you may switch between different subway lines if you wish. All subway lines go in both directions.

Input

Input consists of the x,y coordinates of your home and your school, followed by specifications of several subway lines. Each subway line consists of the non-negative integer x,y coordinates of each stop on the line, in order. You may assume the subway runs in a straight line between adjacent stops, and the coordinates represent an integral number of metres. Each line has at least two stops. The end of each subway line is followed by the dummy coordinate pair -1,-1. In total there are at most 200 subway stops in the city.

Output

Output is the number of minutes it will take you to get to school, rounded to the nearest minute, taking the fastest route.

Sample Input

0 0 10000 1000
0 200 5000 200 7000 200 -1 -1 
2000 600 5000 600 10000 600 -1 -1

Sample Output

21

很有意思,这道题的题意是,一条地铁线上只有相邻的地铁站可以坐地铁,其余的都只能走路,然后给你坐车和走路的速度,让你求出最短的时间。把相邻的地铁站建立成边,然后用最短路走一遍就可以了。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
#define INF 0x3f3f3f3f
#define N 300
struct node
{
    int x,y;
} s[N+10];
double d[N+10],map[N+10][N+10];
int book[N+10],n;
void dijkstra(int x)
{
    int i,j,k,u;
    for( i=1 ; i<=n ; i++ )
    {
        d[i]=map[x][i];
    }
    memset(book,0,sizeof(book));
    book[x]=1;
    for( i=1 ; i<n ; i++ )
    {
        double minn=INF;
        for( j=1 ; j<=n ; j++)
        {
            if(!book[j]&&minn>d[j] )
            {
                minn=d[j];
                u=j;
            }
        }
        book[u]=1;
        for( j=1 ; j<=n ; j++ )
        {
            if(!book[j]&&map[u][j]!=INF&& d[j] > d[u]+map[u][j])
            {
                d[j]=d[u]+map[u][j];
            }
        }
    }
    printf("%.0f",d[2]);
}
double cn(node a,node b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int main()
{
    int i,j,k=3;
    for( i=1 ; i<N ; i++ )
        for( j=1 ; j<N; j++ )
            if(i==j)
                map[i][j] = 0 ;
            else
                map[i][j] = INF ;
    scanf("%d%d%d%d",&s[1].x,&s[1].y,&s[2].x,&s[2].y);
    n=3;
    int x,y;
    while(~scanf("%d%d",&x,&y))
    {
        if(x==-1&&y==-1)
        {
            k=n;
            continue;
        }
        s[n].x=x;
        s[n].y=y;
        if(n!=k)
            map[n][n-1]=map[n-1][n]=cn(s[n],s[n-1])*3/2000;
        n++;
    }
    for( i=1 ; i<=n ; i++)
    {
        for( j=1; j<=n; j++ )
        {
            map[i][j]=map[j][i]=min(map[i][j],cn(s[i],s[j])*3/500);
        }
    }
    dijkstra(1);
    return 0;
}
 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值