HDU 1495 非常可乐

 

 

非常可乐

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18079    Accepted Submission(s): 7334

 

 

Problem Description

大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

 

 

Input

三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。

 

 

Output

如果能平分的话请输出最少要倒的次数,否则输出"NO"。

 

 

Sample Input

 

7 4 3 4 1 3 0 0 0

 

 

Sample Output

 

NO 3

#include<iostream>
#include<queue>
#include<algorithm>
#include<string.h>
#include<cstdio>
int v[4];
bool b[101][101][101];
using namespace std;
struct node
{
    int v[4],step;
} temp;
queue<node> P;
int main()
{
    void bfs();
    while (scanf("%d%d%d", &v[1], &v[2], &v[3]) != EOF)
    {
        if (v[1] == 0 && v[2] == 0 && v[3] == 0)
            break;
        if (v[2] > v[3])
            swap(v[2], v[3]);
        memset(b, 0, sizeof(b));
        node dc;
        dc.v[1] = v[1], dc.v[2] = 0, dc.v[3] = 0, dc.step = 0;
        P.push(dc);
        b[v[1]][v[2]][v[3]] = 1;
        bfs();
    }
    return 0;
}
void bfs()
{
    void pour(int, int);
    while (!P.empty())
    {
        node dc;
        dc=P.front();
        P.pop();
        if (dc.v[3] == dc.v[1] && dc.v[2] == 0)
        {
            printf("%d\n", dc.step);
            while (!P.empty())
                P.pop();
            return;
        }
        for(int i=1; i<=3; i++)
            for (int j = 1; j <= 3; j++) //每个杯子可以倒进另两个杯子,遍历每一种情况
            {
                if (j != i)
                {
                    temp = dc;
                    pour(i, j);
                    if (b[temp.v[1]][temp.v[2]][temp.v[3]] == 0)
                    {
                        P.push(temp);
                        b[temp.v[1]][temp.v[2]][temp.v[3]] = 1;
                    }
                }
            }
    }
    printf("NO\n");
}
void pour(int a, int b)//a中的可乐倒给b
{
    int sum = temp.v[a] + temp.v[b];
    if(sum <= v[b])
        temp.v[a] = 0, temp.v[b] = sum, temp.step++;//a能够全部倒进b
    else
        temp.v[b] = v[b], temp.v[a] = sum - v[b], temp.step++;//a中有剩余
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值