POJ 2392 Space Elevator

Space Elevator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions:12576 Accepted: 5981

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40
所能到达高度最小的应该在最下面,按照g[i].a升序排列
#include<cstdio>
#include<string.h>
#include<algorithm>
int anst[40004];
bool build[40004];
using namespace std;
struct node
{
    int h,a,c;
}g[404];
bool cmp(node a,node b)
{
    return a.a<b.a;
}
int main()
{
    memset(build,0,sizeof(build));
    build[0]=1;
    int n,i,j;scanf("%d",&n);
    for(i=1;i<=n;i++)
        scanf("%d%d%d",&g[i].h,&g[i].a,&g[i].c);
    sort(g+1,g+n+1,cmp);
    for(i=1;i<=n;i++)
    {
        node e=g[i];
        memset(anst,0,sizeof(anst));
        for(j=e.h;j<=40000;j++)
        {
            if(j>e.a)break;
            if(!build[j]&&build[j-e.h]&&anst[j-e.h]<e.c)
            {
                build[j]=1;anst[j]=anst[j-e.h]+1;
            }
        }
    }
    for(i=40000;i>=0;i--)
    {
        if(build[i])
        {
            printf("%d",i);
            break;
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值