POJ 2549 Sumsets

Sumsets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions:11935 Accepted: 3297

Description

Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S.

Input

Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.

Output

For each S, a single line containing d, or a single line containing "no solution".

Sample Input

5
2 
3 
5 
7 
12
5
2 
16 
64 
256 
1024
0

Sample Output

12
no solution

将a+b,c-d看成两个序列,然后二分查找。
注意不要忘记去重

代码:

#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
const int maxn=1000+5;
ll t[maxn],d[maxn*maxn];
struct node
{
    ll sum;
    int use1,use2;
} c[maxn*maxn];
bool cmp(const node& a,const node& b)
{
    return a.sum<b.sum;
}
int main()
{
    int n;
    while(~scanf("%d",&n),n)
    {
        int i,j,s=0;
        for(i=0; i<n; i++)
            scanf("%lld",&t[i]);
        sort(t,t+n);
        for(i=0; i<n; i++)
            for(j=0; j<n; j++)
                if(i!=j)
                {
                    c[s].sum=t[i]+t[j];
                    c[s].use1=i;
                    c[s++].use2=j;
                }
        sort(c,c+s,cmp);
        for(i=0; i<s; i++)
            d[i]=c[i].sum;
        ll ma=-1e17;
        for(i=0; i<n; i++)
        {
            for(j=n-1; j>=0; j--)
            {
                if(i!=j&&t[j]>ma)
                {
                    ll u=-(t[i]-t[j]);
                    int id1=lower_bound(d,d+s,u)-d;
                    int id2=upper_bound(d,d+s,u)-d-1;
                    for(int k=id1;k<id2;k++)
                    {
                        int a=c[k].use1,b=c[k].use2;
                        if(a!=i&&a!=j&&b!=i&&b!=j)
                        {
                            ma=t[j];break;
                        }
                    }
                }
            }
        }
        if(ma!=-1e17)printf("%lld\n",ma);
        else printf("no solution\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值