Sumsets POJ - 2549 (从 一个 1000数中,找出四个数,满足 a + b = d -c,且求的d最大)

Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S.
Input
Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.
Output
For each S, a single line containing d, or a single line containing "no solution".
Sample Input
5
2 
3 
5 
7 
12
5
2 
16 
64 
256 
1024
0
Sample Output
12
no solution

题意:从给出的一段序列中挑取 4个数,a,b,c,d使得a+b = d - c,使得d最大;

思路: n为小于1000的数,取出4个数要是 按一般的取法,一定超时,所以你要想想如何利用二分求解;

若 a + b = d - c;

那么 a + c = d - b;

        b +c = d - a;

所以我们先对序列排序,从大到小枚举 d,而 我们把c 看做 a,b,c 中最大的数, 枚举 d - c 的每一种可能性(为什么要每一种呢,因为a,b,c,d中可能有负数,也就是为什么 代码中那个内层循环中为什么 j = n-1,而不是j = i-1了,要全是正数的话,j = i-1,但是有负数,例:-1.-2,7,10;d 最大为7,而 c = 10) 在利用二分求法求a + b = d - c;

代码:

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define Max 1010
int n;
int a[Max];
int main()
{
	int i,j;
	while(~scanf("%d",&n)&&n)
	{
		for(i = 0; i < n ; i ++)
			scanf("%d",&a[i]);
		sort(a,a+n);
		int flag =0;
		int res;
		for(i = n-1;i>=0;i--)
		{
			for(j = n -1 ;j>=0;j--)  // 
			{
				if(i==j) continue;
				int sum = a[i]- a[j];
				int l = 0,r = j-1;
				while(l<r)
				{
					int tt = a[l] + a[r];
					if(tt==sum)
					{
						flag = 1;
						res = i;
						break;
					}
					if(tt>sum)
						r--;
					else l++;
				}
				if(flag) break;
			}
			if(flag) break;
		}
		if(flag) printf("%d\n",a[res]);
		else printf("no solution\n");
	}
	return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值