HDU 3308 LCIS(线段树区间合并)

LCIS

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8187    Accepted Submission(s): 3512


Problem Description
Given n integers.
You have two operations:
U A B: replace the Ath number by B. (index counting from 0)
Q A B: output the length of the longest consecutive increasing subsequence (LCIS) in [a, b].
 

Input
T in the first line, indicating the case number.
Each case starts with two integers n , m(0<n,m<=10 5).
The next line has n integers(0<=val<=10 5).
The next m lines each has an operation:
U A B(0<=A,n , 0<=B=10 5)
OR
Q A B(0<=A<=B< n).
 

Output
For each Q, output the answer.
 

Sample Input
 
 
1 10 10 7 7 3 3 5 9 9 8 1 8 Q 6 6 U 3 4 Q 0 1 Q 0 5 Q 4 7 Q 3 5 Q 0 2 Q 4 6 U 6 10 Q 0 9
 

Sample Output
 
 
1 1 4 2 3 1 2 5

每个节点的最大值:
取左儿子的最大值和右儿子的最大值中的较大值。
若左儿子的右端小于右儿子的左端则拿求出的最大值与
左儿子的右连续与右儿子的左连续的和相比较。

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+7;
#define lson rt<<1
#define rson rt<<1|1
int a[maxn];
struct node
{
    int left,right,mid;
    int lx,rx,mx;
    int dis(){return right-left+1;}
}c[maxn<<2];
void Push_up(int rt)
{
    c[rt].lx=c[lson].lx+((c[lson].lx==c[lson].dis()&&a[c[lson].right]<a[c[rson].left])?c[rson].lx:0);
    c[rt].rx=c[rson].rx+((c[rson].rx==c[rson].dis()&&a[c[lson].right]<a[c[rson].left])?c[lson].rx:0);
    c[rt].mx=max(max(c[lson].mx,c[rson].mx),((a[c[lson].right]<a[c[rson].left])?c[lson].rx+c[rson].lx:0));
}
void build(int l,int r,int rt)
{
    c[rt].left=l;
    c[rt].right=r;
    c[rt].mid=(l+r)>>1;
    if(l==r)
    {
        c[rt].lx=c[rt].rx=c[rt].mx=1;
        return;
    }
    build(l,c[rt].mid,lson);
    build(c[rt].mid+1,r,rson);
    Push_up(rt);
}
void update(int L,int C,int rt)
{
    if(c[rt].left==c[rt].right)
            return;
    if(L<=c[rt].mid) update(L,C,lson);
    else update(L,C,rson);
    Push_up(rt);
}
int query(int l,int r,int rt)
{
    if(c[rt].left==l&&c[rt].right==r)
        return c[rt].mx;
    if(r<=c[rt].mid) return query(l,r,lson);
    else if(l>c[rt].mid) return query(l,r,rson);
    else
    {
        int lll,llr,sum=0;
        lll=query(l,c[rt].mid,lson);
        llr=query(c[rt].mid+1,r,rson);
        if(a[c[lson].right]<a[c[rson].left])
            sum=min(c[rt].mid-l+1,c[lson].rx)+min(r-c[rt].mid,c[rson].lx);
            //注意控制区间范围。
        return max(sum,max(lll,llr));
    }
}
int main()
{
    int T;scanf("%d",&T);
    while(T--)
    {
        int n,i,j,m;
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
            build(1,n,1);
        while(m--)
        {
            char t[2];int x,y;
            scanf("%s%d%d",&t,&x,&y);
            if(t[0]=='U')
            {
                a[x+1]=y;
                update(x+1,y,1);
            }
            else printf("%d\n",query(x+1,y+1,1));
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值