hdu 5475 An easy problem(线段树)

An easy problem

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2826    Accepted Submission(s): 1056


Problem Description
One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.
1. multiply X with a number.
2. divide X with a number which was multiplied before.
After each operation, please output the number X modulo M.
 

Input
The first line is an integer T( 1T10), indicating the number of test cases.
For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. ( 1Q105,1M109)
The next Q lines, each line starts with an integer x indicating the type of operation.
if x is 1, an integer y is given, indicating the number to multiply. ( 0<y109)
if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It's guaranteed that in type 2 operation, there won't be two same n.
 

Output
For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.
Then Q lines follow, each line please output an answer showed by the calculator.
 

Sample Input
 
 
1 10 1000000000 1 2 2 1 1 2 1 10 2 3 2 4 1 6 1 7 1 12 2 7
 

Sample Output
 
 
Case #1: 2 1 2 20 10 1 6 42 504 84
 

思路:
看成是求n个数的乘积,op==1,把对应点的数字改为x
op==2, 把x位置的数改为1。每次输出1~n的乘积
代码:
#include<bits/stdc++.h>
using namespace std;
#define ll long long 
const int maxn=100005;
ll mod,tree[maxn<<2],X[maxn],K[maxn];
void build(int l,int r,int rt)
{
    if(l==r)
    {
        tree[rt]=1%mod;
        return;
    }
    int mid=(l+r)/2;
    build(l,mid,rt<<1);
    build(mid+1,r,rt<<1|1);
    tree[rt]=tree[rt<<1]*tree[rt<<1|1]%mod;
}
void update(int L,ll C,int l,int r,int rt)
{
    if(l==r)
    {
        tree[rt]=C%mod;
        return;
    }
    int mid=(l+r)/2;
    if(L<=mid)update(L,C,l,mid,rt<<1);
    else update(L,C,mid+1,r,rt<<1|1);
    tree[rt]=tree[rt<<1]*tree[rt<<1|1]%mod;
}
int main()
{
    int T;scanf("%d",&T);
    for(int i=1;i<=T;i++)
    {
        printf("Case #%d:\n",i);
        int Q;scanf("%d%lld",&Q,&mod);
        build(1,100000,1);
        for(int i=1;i<=Q;i++)
        {
            int op;ll x;scanf("%d%lld",&op,&x);
            if(op==1) 
            {
                update(i,x,1,100000,1);
                printf("%lld\n",tree[1]);
            }
            else
            {
                update(x,1,1,100000,1);
                printf("%lld\n",tree[1]);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值