hdu 5475 An easy problem 线段树单点更新



An easy problem

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1763    Accepted Submission(s): 786


Problem Description
One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.
1. multiply X with a number.
2. divide X with a number which was multiplied before.
After each operation, please output the number X modulo M.
 

Input
The first line is an integer T( 1T10 ), indicating the number of test cases.
For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. ( 1Q105,1M109 )
The next Q lines, each line starts with an integer x indicating the type of operation.
if x is 1, an integer y is given, indicating the number to multiply. ( 0<y109 )
if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It's guaranteed that in type 2 operation, there won't be two same n.
 

Output
For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.
Then Q lines follow, each line please output an answer showed by the calculator.
 

Sample Input
  
  
1 10 1000000000 1 2 2 1 1 2 1 10 2 3 2 4 1 6 1 7 1 12 2 7
 

Sample Output
  
  
Case #1: 2 1 2 20 10 1 6 42 504 84
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5932  5931  5930  5929  5928 
 

Statistic |  Submit |  Discuss |  Note

题意:给出Q个操作,分为两种:乘以一个数或者除以一个之前之前乘过的数(给出操作序号,一个序号不会出现两次)。要求对M取模。


问每一步最后的结果。


解法:直接线段树单点更新即可。



#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
using namespace std;

#define all(x) (x).begin(), (x).end()
#define for0(a, n) for (int (a) = 0; (a) < (n); (a)++)
#define for1(a, n) for (int (a) = 1; (a) <= (n); (a)++)
#define mes(a,x,s)  memset(a,x,(s)*sizeof a[0])
#define mem(a,x)  memset(a,x,sizeof a)
#define ysk(x)  (1<<(x))
typedef long long ll;
typedef pair<int, int> pii;
const int INF =0x3f3f3f3f;
const int maxn= 1e5+0.5   ;

int Q;ll mod;

struct SegmentTree
{
    int le[4*maxn+3],ri[4*maxn+3];
    ll C[4*maxn+3];
    void build(int ind,int L,int R)
    {
        le[ind]=L,ri[ind]=R;
        if(L==R)
        {
            C[ind]=1%mod;
            return;
        }
        int mid=(L+R)>>1;
        build(ind<<1,L,mid);
        build(ind<<1|1,mid+1,R);
        C[ind]=C[ind<<1]*C[ind<<1|1]%mod;
    }
    void update(int ind,int pos,ll x)
    {
        if(le[ind]==ri[ind])
        {
            C[ind]=x%mod;
            return;
        }
        int mid=(le[ind]+ri[ind])>>1;
        if(pos<=mid)  update(ind<<1,pos,x);
        else  update(ind<<1|1,pos,x);
        C[ind]=C[ind<<1]*C[ind<<1|1]%mod;
    }

}sgt;
int main()
{
   std::ios::sync_with_stdio(false);
   ll x;int id;
   int T,op,kase=0;cin>>T;
   while(T--)
   {
      cin>>Q>>mod;
      printf("Case #%d:\n",++kase);
      sgt.build(1,1,Q);
      for1(i,Q)
      {
        cin>>op;
        if(op==1)
        {
           cin>>x;
           sgt.update(1,i,x);
        }
        else
        {
           cin>>id;
           sgt.update(1,id,1);
        }
        ll ans=sgt.C[1];
        printf("%lld\n",ans);
      }
   }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值