windows指定python版本安装kafka

背景:

在window上运行测试代码时,需要连接kafka,报错信息:AssertionError: Unrecognized configs: {'max_poll_interval_ms': 600000}  经过排查是跟windows上的kafka版本冲突,需要在windows上安装其他版本kafka

解决方法:

先将原有的kafka卸载

C:\7-9\datainterface\test\Scripts\python.exe   -m   pip   uninstall   kafka

再执行安装操作

C:\7-9\datainterface\test\Scripts\python.exe   -m   pip   install        kafka-python

找到自己项目引用的环境目录比如我的引用的环境是:

执行即可。

©️2020 CSDN 皮肤主题: 技术工厂 设计师:CSDN官方博客 返回首页