(PAT 1134) Vertex Cover (图中边和顶点的关系)

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

解题思路:

题目的意思是,给出M条无向边,之后给出若干组集合,判断与每条边向连的顶点是否属于集合中至少某一个元素,如果所有的边满足该条件,输出yes,如果某条边两边的顶点不属于集合中任何一个元素,输出No

我们可以把两个顶点之间那条边的边号与两个顶点绑定(通过vector容器)这样就得到了每个顶点的与之相连的边,然后我们把集合中每个顶点的边集加入到一个新的set中,由于set是不允许重复的,所以如过set的size()小于边数的话,说明有若干条边与集合中的顶点都没有关系,那么输出NO,反之输出Yes

#include <iostream>
#include <set>
#include <algorithm>
#include <vector>
#include <string.h>
using namespace std;
const int MAXN = 10010;
vector<int> EDGES[MAXN];

bool flagSet[MAXN];
int main() {
	int N, M;
	cin >> N >> M;
	for (int i = 0; i < M; ++i) {
		int nx, ny;
		cin >> nx >> ny;
		EDGES[nx].push_back(i);
		EDGES[ny].push_back(i);
	}
	int K;
	cin >> K;
	for (int i = 0; i < K; ++i) {
		int n;
		scanf("%d", &n);
		set<int> nodeSet;
		for (int j = 0; j < n; ++j) {
			int node;
			scanf("%d", &node);
			for (int i = 0; i < EDGES[node].size(); ++i) {
				nodeSet.insert(EDGES[node][i]);
			}
		}
		
		if (nodeSet.size() < M) {
			cout << "No" << endl;
		}
		else {
			cout << "Yes" << endl;
		}
	}

	system("PAUSE");
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值