(PAT 1125) Chain the Ropes (贪心+优先级队列的应用)

1125 Chain the Ropes (25 point(s))

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10​4​​). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 10​4​​.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

解题思路:

用一个优先级队列进行维护,确保最小的元素在队首,每次从队列中挑出最小的两个元素,合并后放回队列

以此类推,最后得到的那个元素就是最大的

#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
const int MAXN = 10010;
int ropes[MAXN];

int main() {
	int N;
	cin >> N;
	priority_queue<int,vector<int>,greater<int>> ropes_queue;
	for (int i = 0; i < N; ++i) {
		int num;
		cin >> num;
		ropes_queue.push(num);
	}
	while (!ropes_queue.empty()) {
		if (ropes_queue.size() == 1) {
			cout << ropes_queue.top() << endl;
			system("PAUSE");
			return 0;
		}
		int temA = ropes_queue.top();
		ropes_queue.pop();
		int temB = ropes_queue.top();
		ropes_queue.pop();
		double temC = (temA + temB)*1.0 / 2;  //四舍五入
		ropes_queue.push((int)temC);
	}
	system("PAUSE");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值