PAT-A1125/B1070 Chain the Ropes/结绳 题目内容及题解

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

给定一段一段的绳子,你需要把它们串成一条绳。每次串连的时候,是把两段绳子对折,再如下图所示套接在一起。这样得到的绳子又被当成是另一段绳子,可以再次对折去跟另一段绳子串连。每次串连后,原来两段绳子的长度就会减半。

Your job is to make the longest possible rope out of N given segments.

给定 N 段绳子的长度,你需要找出它们能串成的绳子的最大长度。

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10^​4​​). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 10^​4​​.

每个输入包含 1 个测试用例。每个测试用例第 1 行给出正整数 N (2≤N≤10​^4​​);第 2 行给出 N 个正整数,即原始绳段的长度,数字间以空格分隔。所有整数都不超过10^​4​​。

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

在一行中输出能够串成的绳子的最大长度。结果向下取整,即取为不超过最大长度的最近整数。

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

解题思路

越是早加入的绳结折叠次数越多,因此利用贪心算法求解:

  1. 读入数据序列并将其排序;
  2. 依次计算直到队列结束;
  3. 按照题目要求输出结果并返回零值。

代码

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;

vector<int> seq;

int main(){
    int i,N,a;
    int res;
    scanf("%d",&N);
    for(i=0;i<N;i++){
        scanf("%d",&a);
        seq.push_back(a);
    }
    sort(seq.begin(),seq.end());
    res=seq[0];
    for(i=1;i<N;i++){
        res=(res+seq[i])/2;
    }
    printf("%d\n",res);
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值