1121 Damn Single

1121 Damn Single
“Damn Single (单身狗)” is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID’s which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID’s of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:
First print in a line the total number of lonely guests. Then in the next line, print their ID’s in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:
5
10000 23333 44444 55555 88888
分析:先用map类型存储情侣双方的值。
输入M个数据,先判断是否在情侣中,如果不在,则是单身。
在情侣中,再判断情侣是否在party中,如果不在,则视为单身。
参考代码:

#include<iostream>
#include<vector>
#include<cstring>
#include<algorithm>
#include<map>
#include<set>
#define N 100008
int a[N];
using namespace std;
int main()
{
	memset(a, 0, sizeof(int)*(N));
	map<int, int>couple;
	set<int>s;
	int n,m, man, woman;
	scanf("%d", &n);
	for (int i = 1; i <= n; i++) {
		scanf("%d%d", &man, &woman);
		couple[man] = woman;
		couple[woman] = man;
		s.insert(man);
		s.insert(woman);
	}
	scanf("%d", &m);
	vector<int>res(m);
	for (int i = 0; i < m; i++) {
		scanf("%d", &res[i]);
		a[res[i]] = 1;
	}
	vector<int>v;
	sort(res.begin(), res.end());
	int flag = 0,  cnt = 0;

	for (auto val : res) {   //遍历
		flag = 0;
		if (s.count(val) == 0)
			flag = 1;
		else {
			int partner = couple[val];
			if (a[partner] == 0)
				flag = 1;
		}
		if (flag) {
			cnt++;
			v.push_back(val);
		}
	}
	printf("%d\n", cnt);
	flag = 0;
	if(cnt)
	for (auto val : v) {
		if (flag)printf(" "); 
		printf("%05d", val);
		flag = 1;
	}

	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值