PAT甲级1002

1002. A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.

计算两个多项式的和。

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

每个输入文件包含一个测试用例。每个例子有两行,每一行分别是一个多项式的信息:K N1 aN1 N2 aN2 ... NK aNK。K是这个多项式中不为0的项的个数,Ni and aNi (i=1, 2, ..., K)是指数和系数。1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000。

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

以跟输入相同的形式输出A+B的结果。需要注意的是在每一行结尾没有多余的空格。输出精确到小数点后一位。

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

#include<stdio.h>
#include<cstring>
#include<math.h>
#include<iostream>
#include <algorithm>
#include<cmath>
using namespace std;
int main()
{
	float sum[1001];
	for(int i=0;i<1001;i++)
		sum[i]=0;
	
	int n=0,num=0,k=0;
	float nn=0.0;
	for(int i=0;i<2;i++)
	{
		cin>>k;
		for(int j=0;j<k;j++)
		{
			cin>>n;
			cin>>nn;
			sum[n]+=nn;
		}
	}
	
	for(int i=0;i<1001;i++)
	{
		if(sum[i]!=0)
			num++;
	}
	cout<<num;
	for(int i=1000;i>=0;i--)
	{
		if(sum[i]!=0)
		{
			cout<<" "<<i<<" ";
			printf("%.1f",sum[i]);
		}
	}
	system("pause");
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值