1002. A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
也是简单的模拟题,但是要注意两项加起来为零的情况。
代码如下:
#include <iostream>  
#include <fstream>  
#include <vector>  
#include <iomanip>  
using namespace std;  
   
   
struct item  
{  
    item(){}  
    item(int e, double c)  
    {  
        this->exp = e;  
        this->coef = c;  
    }  
    int exp;  
    double coef;  
};  
void merge(item *items1, item *items2, int a, int b);  
int main()  
{  
    //fstream cin("a.txt");  
   
    int a,b;  
    cin>>a;  
    int tmp = a;  
    item *items1 = new item[a];  
    while (tmp--)  
    {  
        int exp;  
        double coef;  
        cin>>exp>>coef;  
        item it(exp, coef);  
        items1[a - tmp - 1] = it;  
    }  
    cin>>b;  
    tmp = b;  
    item *items2 = new item[b];  
    while (tmp--)  
    {  
        int exp;  
        double coef;  
        cin>>exp>>coef;  
        item it(exp, coef);  
        items2[b - tmp - 1] = it;  
    }  
   
    merge(items1, items2, a, b);  
    return 0;  
}  
   
void merge(item *items1, item *items2, int a, int b)  
{  
    vector<item> v;  
    int i = 0,j = 0;  
    for(;i < a && j < b;)  
    {  
        if(items1[i].exp > items2[j].exp)  
        {  
            if(items1[i].coef != 0)  
                v.push_back(items1[i]);  
            i++;  
        }  
        else if(items1[i].exp < items2[j].exp)  
        {  
            if(items2[j].coef != 0)  
                v.push_back(items2[j]);  
            j++;  
        }  
        else 
        {  
            item it(items1[i].exp, items1[i].coef + items2[j].coef);  
            if (it.coef != 0)  
                v.push_back(it);  
            i++;  
            j++;  
        }  
    }  
   
    if(i == a)  
    {  
        while (j < b)  
        {  
            if(items2[j].coef != 0)  
                v.push_back(items2[j]);  
            j++;  
        }  
    }  
    else 
    {  
        while (i < a)  
        {  
            if(items1[i].coef != 0)  
                v.push_back(items1[i]);  
            i++;  
        }  
    }  
   
    cout<<v.size();  
    for (int i = 0; i < v.size(); i++)  
    {  
        cout<<" "<<v[i].exp<<" "<<fixed<<setprecision(1)<<v[i].coef;  
    }  
    cout<<endl;  
}  



                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值