1028 List Sorting-PAT甲级

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

简单的排序

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=100005;
struct Stu{
	int id,score;
	string name;
	Stu(){}
	Stu(int ii,string nn,int ss){
		id=ii;
		name=nn;
		score=ss;
	}
}stu[N];
bool cmp1(Stu a,Stu b){
	return a.id<b.id;
}
bool cmp2(Stu a,Stu b){
	if(a.name!=b.name)
		return a.name<b.name;
	return a.id<b.id;
}
bool cmp3(Stu a,Stu b){
	if(a.score!=b.score)
		return a.score<b.score;
	return a.id<b.id;
}
int n,c;
int main(){
	scanf("%d%d",&n,&c);
	for(int i=0;i<n;i++){
		int id,score;
		string name;
		cin>>id>>name>>score;
		stu[i]={id,name,score};
	}
	if(c==1){
		sort(stu,stu+n,cmp1);
	}else if(c==2){
		sort(stu,stu+n,cmp2);
	}else if(c==3){
		sort(stu,stu+n,cmp3);
	}
	for(int i=0;i<n;i++){
		printf("%06d %s %d\n",stu[i].id,stu[i].name.c_str(),stu[i].score);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值