1148 Werewolf - Simple Version-PAT甲级

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were NNN players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer NNN (5≤N≤1005 \le N \le 1005≤N≤100). Then NNN lines follow and the iii-th line gives the statement of the iii-th player (1≤i≤N1 \le i \le N1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M]A = { a[1], ..., a[M] }A=a[1],...,a[M] and B=b[1],...,b[M]B = { b[1], ..., b[M] }B=b[1],...,b[M], if there exists 0≤k<M0 \le k < M0≤k<M such that a[i]=b[i]a[i]=b[i]a[i]=b[i] (i≤ki \le ki≤k) and a[k+1]<b[k+1]a[k+1]<b[k+1]a[k+1]<b[k+1], then AAA is said to be smaller than BBB. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

简单暴力枚举,题目中要求按照字典序输出,则从编号小者开始枚举,说谎的状态共有两种:一是其应该是狼人,但没有说其为狼人,第二种是其不是狼人,但是称其为狼人;然后通过说谎者的编号与枚举的狼人的编号对比,查看是否是狼人在说谎即可,遇到满足的解则输出。

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=105;
int p[N];
int n;
int main(){
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
		scanf("%d",&p[i]);
	for(int i=1;i<n;i++){
		for(int j=i+1;j<=n;j++){
			//枚举玩家i与j是狼人
			int l=0,wl=0;//l是总共的说谎者
			//wl是狼人中的说谎者
			for(int k=1;k<=n;k++){
				//枚举所有玩家说的话
				if(p[k]>0&&(p[k]==i||p[k]==j)){
					//说谎的第一种情况,是狼人但没有说出来
					l++;
					if(k==i||k==j)
						wl++; 
				}else if(p[k]<0&&abs(p[k])!=i&&abs(p[k])!=j){
					//说谎的第二种情况,不是狼人,但被称为狼人
					 l++;
					 if(k==i||k==j)
					 	wl++;
				}
			}
			if(l==2&&wl==1){
				printf("%d %d\n",i,j);//枚举狼人 
				return 0;
			}
				
		} 
	}
	printf("No Solution\n");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值