1099 Build A Binary Search Tree-PAT甲级(树的建立与遍历)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

二叉搜索树的一组数据域按照从小到大的顺寻排列就是其中序遍历的结果,按照中序遍历的结果对其进行中序遍历,将数据域添加到每一个结点当中,然后对重建后的树进行层次遍历即可

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=105;
struct Node{
	int v;//数据域
	int left=-1;
	int right=-1; 
}node[N];
int in[N],n;
void in_order(int root,int &index){
	if(root==-1)
		return;
	in_order(node[root].left,index);
	node[root].v=in[index];
	index++;
	in_order(node[root].right,index);
}
void level_order(int root){
	queue<int>q;
	q.push(root);
	int flag=0;
	while(!q.empty()){
		int x=q.front();
		q.pop();
		if(flag) printf(" ");
		printf("%d",node[x].v);
		flag=1;
		if(node[x].left!=-1){
			q.push(node[x].left);
		}
		if(node[x].right!=-1){
			q.push(node[x].right);
		}
	}
}
int main(){
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d%d",&node[i].left,&node[i].right);
	}
	for(int i=0;i<n;i++){
		scanf("%d",&in[i]);
	}
	sort(in,in+n);
	int root=0,index=0;
	in_order(root,index);
	level_order(0);
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值