1007 Maximum Subsequence Sum-PAT甲级

本文介绍了一种求解最大连续子序列和的算法,通过动态规划思想,使用结构体存储子序列的起始位置、结束位置及和,解决了给定整数序列中寻找最大连续子序列的问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

求最大的连续子序列的和,用dp[i]来表示最末尾一个元素是第i个元素时的最大的子序列的和,用结构体来表示起始位、结束位以及和,利用动态规划的思想来求解

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=10005;
struct node{
	int first=0,sum=0,last;
	node(){}
	node(int f,int s,int l){
		first=f;
		sum=s;
		last=l;
	}
};
node dp[N];//存储最末尾元素为第i个的子序列的和 
int p[N],k,first=0,last=0,sum;
int main(){
	scanf("%d",&k);
	int flag=0;
	for(int i=1;i<=k;i++){
		scanf("%d",&p[i]);
		if(p[i]>=0){
			flag=1;
		}
	}
	if(!flag){
		printf("0 %d %d\n",p[1],p[k]);
		return 0;
	}
	int max_sum=-0x3f3f3f3f;
	node nd;
	for(int i=1;i<=k;i++){
		if(dp[i-1].sum+p[i]>p[i]){
			dp[i].sum=dp[i-1].sum+p[i];
			dp[i].first=dp[i-1].first;
			dp[i].last=i;
		}else{
			dp[i].sum=p[i];
			dp[i].first=i;
			dp[i].last=i;
		}
		if(dp[i].sum>max_sum){
			max_sum=dp[i].sum;
			nd=dp[i];
		}
	}
	printf("%d %d %d\n",nd.sum,p[nd.first],p[nd.last]);
	return 0;
}

 

内容概要:本文档提供了三种神经网络控制器(NNPC、MRC和NARMA-L2)在机器人手臂模型上性能比较的MATLAB实现代码及详细解释。首先初始化工作空间并设定仿真参数,包括仿真时间和采样时间等。接着定义了机器人手臂的二阶动力学模型参数,并将其转换为离散时间系统。对于参考信号,可以选择方波或正弦波形式。然后分别实现了三种控制器的具体算法:MRC通过定义参考模型参数并训练神经网络来实现控制;NNPC利用预测模型神经网络并结合优化算法求解控制序列;NARMA-L2则通过两个神经网络分别建模f和g函数,进而实现控制律。最后,对三种控制器进行了性能比较,包括计算均方根误差、最大误差、调节时间等指标,并绘制了响应曲线和跟踪误差曲线。此外,还强调了机器人手臂模型参数的一致性和参考信号设置的规范性,提出了常见问题的解决方案以及性能比较的标准化方法。 适合人群:具备一定编程基础,特别是熟悉MATLAB编程语言的研究人员或工程师,以及对神经网络控制理论有一定了解的技术人员。 使用场景及目标:①理解不同类型的神经网络控制器的工作原理;②掌握在MATLAB中实现这些控制器的方法;③学会如何设置合理的参考信号并保证模型参数的一致性;④能够根据具体的性能指标对比不同控制器的效果,从而选择最适合应用场景的控制器。 其他说明:本文档不仅提供了完整的实验代码,还对每个步骤进行了详细的注释,有助于读者更好地理解每段代码的功能。同时,针对可能出现的问题给出了相应的解决办法,确保实验结果的有效性和可靠性。为了使性能比较更加公平合理,文档还介绍了标准化的测试流程和评估标准,这对于进一步研究和应用具有重要的指导意义。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值