Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
求最大的连续子序列的和,用dp[i]来表示最末尾一个元素是第i个元素时的最大的子序列的和,用结构体来表示起始位、结束位以及和,利用动态规划的思想来求解
满分代码如下:
#include<bits/stdc++.h>
using namespace std;
const int N=10005;
struct node{
int first=0,sum=0,last;
node(){}
node(int f,int s,int l){
first=f;
sum=s;
last=l;
}
};
node dp[N];//存储最末尾元素为第i个的子序列的和
int p[N],k,first=0,last=0,sum;
int main(){
scanf("%d",&k);
int flag=0;
for(int i=1;i<=k;i++){
scanf("%d",&p[i]);
if(p[i]>=0){
flag=1;
}
}
if(!flag){
printf("0 %d %d\n",p[1],p[k]);
return 0;
}
int max_sum=-0x3f3f3f3f;
node nd;
for(int i=1;i<=k;i++){
if(dp[i-1].sum+p[i]>p[i]){
dp[i].sum=dp[i-1].sum+p[i];
dp[i].first=dp[i-1].first;
dp[i].last=i;
}else{
dp[i].sum=p[i];
dp[i].first=i;
dp[i].last=i;
}
if(dp[i].sum>max_sum){
max_sum=dp[i].sum;
nd=dp[i];
}
}
printf("%d %d %d\n",nd.sum,p[nd.first],p[nd.last]);
return 0;
}