Linux GUI自动化测试工具x11 GUITest in Linux x86

Linux GUI自动化测试工具x11 GUITest;QT GUI自动化测试工具x11 GUITest。

一、X11GUITest安装

在linux下安装perl X11::GUITest的操作步骤:

1.在下面所给的网址中下载X11-GUITest,网址为:http://sourceforge.net/projects/x11guitest/直接download,

2.解压:tar zxvf X11-GUITest-0.28.tar.gz

3.一般Linux系统下,都默认有perl,如果没有,下载perl:http://www.cpan.org

用wget http://www.cpan.org/src/perl-5.10.0.tar.gz下载perl压缩包在进行解压,下载完成后解压安装。

#tar zxvf perl-5.10.0.tar.gz

#cd perl-5.10.0

#./Configure -des -Dprefix=/usr/local/perl

  (参数-Dprefix指定安装目录为/usr/local/perl)

#make

#make test

#make install

接下来替换系统原有的perl.

#mv /usr/bin/perl /usr/bin/perl.bak

#ln -s /usr/local/perl/bin/perl /usr/bin/perl

#perl -v

如果执行perl -v 和出现如下提示的话.就是安装成功了。

This is perl, v5.10.0 built for i686-linux

Copyright 1987-2007, Larry Wall…………………………

4.安装X11::GUITest,使用以下命令:

(1) 执行perl Makefile.PL

注:执行后会提示can't locate Exutils/Makefile.pm in @INC…,说明没有安装perl模块。

解决方法如下:

#wget http://files.directadmin.com/services/9.0/ExtUtils-MakeMaker-6.31.tar.gz

#tar xvzf ExtUtils-MakeMaker-6.31.tar.gz

#cd ExtUtils-MakeMaker-6.31

#perl Makefile.PL

#make

#make install 如果还是出现下列的提示,Can't locate ExtUtils/MakeMaker.pm in @INC (@INC contains: /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5 .) at Makefile.PL line 1. BEGIN failed–compilation aborted at Makefile.PL line 1.

这里需要先要安装perl-devel,perl-CPAN .Fedora下直接yum命令就可以成功安装,例如yum -y install perl-devel

(2)执行make命令,

注:如果编译出现错误,需要根据错误提示,安装依赖包libX11-devel.libXt-devel,libXtst-devel;例如,yum install libXt-devel / opkg install libxt-dev (在arm架构下使用) yum install libXtst-devel / opkg install libxtst-dev(在arm架构下使用)

(3) 执行make test

(4) 执行 make install

二、实际使用:

cd eg/,运行实际给的例子看看效果吧。For additional examples, please look under the 'eg/' sub-directory from the installation folder.参考链接:http://search.cpan.org/~ctrondlp/X11-GUITest-0.28/GUITest.pm

三、Recorder安装you'd like to install the recorder, use these steps:

  1. cd recorder
  2. ./autogen.sh
  3. ./configure
  4. make
  5. make install
  6. 进入src目录下,执行./x11guirecord –help

这里编译之前也需要一些依赖包要提前先安装好,需要安装popt-devel等,如yum install popt-devel

不过尝试了下,发现Recorder录制的都是基于坐标位置的,不太好用

相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页