POJ 3614 Sunscreen

Sunscreen
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3317 Accepted: 1171

Description

To avoid unsightly burns while tanning, each of the C (1 ≤ C ≤ 2500) cows must cover her hide with sunscreen when they're at the beach. Cow i has a minimum and maximum SPFrating (1 ≤ minSPFi ≤ 1,000; minSPFi ≤ maxSPFi ≤ 1,000) that will work. If the SPF rating is too low, the cow suffers sunburn; if the SPF rating is too high, the cow doesn't tan at all........

The cows have a picnic basket with L (1 ≤ L ≤ 2500) bottles of sunscreen lotion, each bottle i with an SPF rating SPFi (1 ≤ SPFi ≤ 1,000). Lotion bottle i can cover coveri cows with lotion. A cow may lotion from only one bottle.

What is the maximum number of cows that can protect themselves while tanning given the available lotions?

Input

* Line 1: Two space-separated integers: C and L
* Lines 2..C+1: Line i describes cow i's lotion requires with two integers: minSPFi and maxSPFi 
* Lines C+2..C+L+1: Line i+C+1 describes a sunscreen lotion bottle i with space-separated integers: SPFi and coveri

Output

A single line with an integer that is the maximum number of cows that can be protected while tanning

Sample Input

3 2
3 10
2 5
1 5
6 2
4 1

Sample Output

2

Source

思路:优先队列+贪心
AC 代码:
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
typedef pair<int,int> p;
priority_queue <int,vetor<int>,greater<int>> q;
p niu[2501],bot[2501];
bool cmp(p x, p y)
{
  return x.first<y.first;
}
int main()
{
  int c,l,i,j,sum;
  cin>>c>>l;
  for(i=0;i<c;i++)
    cin>>niu[i].first>>niu[i].second;
  for(i=0;i<l;i++)
    cin>>bot[i].first>>bot[i].second;
    sort(niu,niu+c,cmp);
    sort(bot,bot+l,cmp);
    j=0;sum=0;
    for(i=0;i<l;i++)
    {
      while(j<c&&niu[j].first<=bot[i].first)
      {
        q.push(niu[j].second);
        j++;
      } 
      while(!q.empty()&&bot[i].second)
      {
        int temp = q.top();
        q.pop();
        if(temp < bot[i].first) continue;
        sum++;
        bot[i].second--;
      }               
    }
    cout<<sum<<endl;
  system("pause");
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值