hdoj5645DZY Loves Balls

Problem Description
DZY loves playing balls.

He has  n balls in a big box. On each ball there is an integer written.

One day he decides to pick two balls from the box. First he randomly picks a ball from the box, and names it  A. Next, without putting  A back into the box, he randomly picks another ball from the box, and names it  B.

If the number written on  A is strictly greater than the number on  B, he will feel happy.

Now you are given the numbers on each ball. Please calculate the probability that he feels happy.
 

Input
First line contains  t denoting the number of testcases.

t testcases follow. In each testcase, first line contains  n, second line contains  n space-separated positive integers  ai, denoting the numbers on the balls.

( 1t300,2n300,1ai300)
 

Output
For each testcase, output a real number with 6 decimal places. 
 

Sample Input
 
   
2 3 1 2 3 3 100 100 100
 
Sample Output
 
   
0.500000 0.000000
 代码:
#include<stdio.h>
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		int i,j,a[9999];
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
		}
		double sum;
		sum=n*(n-1);
		double ans=0;
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				if(a[j]>a[i])
				ans++;
			}
		}
		double p;
		p=ans/sum;
		printf("%.6lf\n",p);
	}
	return 0;
}
思路:签到水题。

转载于:https://www.cnblogs.com/mfmdaoyou/p/7337902.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值