A + B Problem II

Time limit               1000 ms
Memory limit          32768 kB
OS                         Windows


I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 


Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 


Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 


Sample Input
2
1 2
112233445566778899 998877665544332211


Sample Output
Case 1:
1 + 2 = 3


Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110


#include<stdio.h>
#include<string.h>
int main()
{
int p,i,j,m[1000],n[1000],s[1000],x=1,d;
char a[1000],b[1000];
scanf("%d",&p);
while(p--)
{
memset(s,0,sizeof(s));
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(m,0,sizeof(m));
memset(n,0,sizeof(n));
scanf("%s %s",a,b);
d=(strlen(a)>strlen(b)?strlen(a):strlen(b))-1;
for(i=d+1-strlen(a);i<=d;i++)
m[i]=a[i-d-1+strlen(a)]-48;
for(j=d+1-strlen(b);j<=d;j++)
n[j]=b[j-d-1+strlen(b)]-48;
for(i=d;i>=0;i--)
{
s[i+1]+=(m[i]+n[i]);
s[i]=s[i+1]/10;
s[i+1]%=10;
}
printf("Case %d:\n",x);
for(i=d+1-strlen(a);i<=d;i++)
printf("%d",m[i]);
printf(" + ");
for(i=d+1-strlen(b);i<=d;i++)
printf("%d",n[i]);
printf(" = ");
if(s[0]!=0)
printf("%d",s[0]);
for(i=1;i<=d+1;i++)
printf("%d",s[i]);
printf("\n");
if(p>0)
printf("\n");
x++;
}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值