杭电oj-1002(A + B Problem II)

题目链接:A + B Problem II

问题描述

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

题目大意

给定数字a、b,计算a+b的和。例如,给定a=112233445566778899,b=998877665544332211,则和为1111111111111111110。

解题思路

由于数据过大,无法使用long long存储数据,因此使用char类型数组来储存数据,逐位进行计算

代码

#include <stdio.h>
#include <string.h>
#include <iostream>

char s1[1000], s2[1000];
int a[1000], b[1000], c[1000];

using namespace std;

int main() {
    int T, count = 1;
    cin >> T;
    while (T--) {
        // 初始化
        memset(a, 0, sizeof(a));
        memset(b, 0, sizeof(b));
        memset(c, 0, sizeof(c));
        long i = 0, j = 0;
        
        // 读取a,b
        scanf("%s %s", s1, s2);
        cout << "Case " << count << ":" << endl;
        cout << s1 << " + " << s2 << " = ";
        
        long a_len = strlen(s1), b_len = strlen(s2);
        if (a_len > b_len) {
            char temp[1000];
            strcpy(temp, s1);
            strcpy(s1, s2);
            strcpy(s2, temp);
            a_len = strlen(s1);
            b_len = strlen(s2);
        }
        
        //将a,b转为数字
        for (i = a_len-1, j = 0; i >= 0; i--) {
            a[i] = s1[i] - '0';
            c[j++] = a[i];
        }
        
        for (i = b_len-1, j = 0; i >= 0; i--) {
            b[i] = s2[i] -'0';
            c[j++] += b[i];
        }
        
        long max_len = (a_len > b_len) ? a_len : b_len;
        int temp = 0;
        for (i = 0; i < max_len; i++) {
            c[i] += temp;
            temp = c[i] / 10;
            c[i] = c[i] % 10;
            if (i == max_len-1 && temp != 0) {
                c[j++] = temp;
            }
        }
        
        for (i = j-1; i >= 0; i--)
            cout << c[i];
        
        cout << endl;
        if (T) {
            cout << endl;
        }
        count++;
    }
    
    return 0;
}

个人学习经验,欢迎各位指导

  • 26
    点赞
  • 12
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
杭州电子科技大学在线评测系统(杭电OJ)中的题目1000-1100是一系列编程题,我将分别进行回答。 1000题是一个简单的入门题,要求计算两个整数的和。我们可以使用一个简单的算法,读取输入的两个整数,然后将它们相加,最后输出结果即可。 1001题是一个稍微复杂一些的题目,要求实现字符串的逆序输出。我们可以使用一个循环来逐个读取输入的字符,然后将这些字符存储在一个数组中。最后,我们可以倒序遍历数组并将字符依次输出,实现字符串的逆序输出。 1002题是一个求最大公约数的问题。我们可以使用辗转相除法来解决,即先求出两个数的余数,然后将被除数更新为除数,将除数更新为余数,直至两个数的余数为0。最后的被除数就是最大公约数。 1003题是一个比较简单的排序问题。我们可以使用冒泡排序算法来解决,即每次比较相邻的两个元素,如果它们的顺序错误就交换它们的位置。重复这个过程直至整个数组有序。 1100题是一个动态规划问题,要求计算给定序列中的最长上升子序列的长度。我们可以使用一个数组dp来保存到达每个位置的最长上升子序列的长度。每当遍历到一个位置时,我们可以将其和之前的位置比较,如果比之前位置的值大,则将其更新为之前位置的值加1,最后返回dp数组的最大值即可。 以上是对杭电OJ1000-1100题目的简要回答,涉及了一些基本的编程知识和算法思想。希望对您有所帮助。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值