POJ-2533 Longest Ordered Subsequence

2 篇文章 0 订阅
2 篇文章 0 订阅

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence ( a1, a2, …, aN) be any sequence ( ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

题意:给定一个数组 求它的最长上升子序列
dp入门题
用a[]数组表示字符串序列
f[]数组表示包含 当前元素的最长上升子序列的长度
即f[i]就表示以第i个元素结尾的最长上升子序列的长度
把数组遍历一遍
当i==1时 f[i]=a[1];
当i>1时 把a[1]到a[i-1]依次和a[i]比较 如果a[i]>a[j],
那就可以把a[i]这个元素加到a[j]代表的序列上去 即以a[i]结尾的最长上升子序列的长度是以a[j]结尾的最长上升子序列的长度+1;

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;
int main()
{
    int f[1100],a[1100];
    int n;
    while(~scanf("%d",&n))
    {
        memset(f,0,sizeof(f));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            f[i]=1;
        }
        int Max=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<i;j++)
            {
                if(a[i] > a[j]){
                    f[i] = max(f[i],f[j]+1);//如果a[i]>a[j],比较f[i]自身的值和更新的值  取大的 
                }
            }
        }

        //将f[i]的值遍历 最大的那个就是最长递增子序列的长度 
        for(int i=1;i<=n;i++){
            if(f[i] >= Max){
                Max = f[i];
            }
        }

        printf("%d\n",Max);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值