2417_Lowest Bit

Lowest Bit

Time Limit: 2 Seconds Memory Limit: 65536 KB

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.


Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.


Output

For each A in the input, output a line containing only its lowest bit.


Sample Input

26
88
0


Sample Output

2
8



Author: SHI, Xiaohan

Source: Zhejiang University Local Contest 2005

 给一个10进制数, 求它二进制后, 从最低位1开始构成的数。88的二进制为1011000,1000 结果是 8 26 的二进制为 11010 10 结果是 2 循环取余,找到第一个 1 为止

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
	int num;
	int a;
	int count;
    while(cin>>num&&num)
	{ 
	  count=0;
	  while(num!=0)//二进制依次从低位到高位求
	  {   
		a=num%2;
        if(a==0)
			count++;
		else//遇到第一个1即停止
			break;
		num=num/2;

		//cout<<a<<endl;
	  }
       cout<<pow(2,count)<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值