uva Cube painting

 Cube painting 

We have a machine for painting cubes. It is supplied with three different colors: blue, red and green. Each face of the cube gets one of these colors. The cube's faces are numbered as in Figure 1.

 

picture21

 

 

Figure 1.

Since a cube has 6 faces, our machine can paint a face-numbered cube in tex2html_wrap_inline126 different ways. When ignoring the face-numbers, the number of different paintings is much less, because a cube can be rotated. See example below. We denote a painted cube by a string of 6 characters, where each character is a br, or g. The tex2html_wrap_inline128 character ( tex2html_wrap_inline130 ) from the left gives the color of face i. For example, Figure 2 is a picture of rbgggr and Figure 3 corresponds to rggbgr. Notice that both cubes are painted in the same way: by rotating it around the vertical axis by 90 tex2html_wrap_inline134 , the one changes into the other.

tex2html_wrap138 tex2html_wrap140

Input

The input of your program is a textfile that ends with the standard end-of-file marker. Each line is a string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the remaining 6 characters give you the representation of another cube. Your program determines whether these two cubes are painted in the same way, that is, whether by any combination of rotations one can be turned into the other. (Reflections are not allowed.)

 

Output

The output is a file of boolean. For each line of input, output contains TRUE if the second half can be obtained from the first half by rotation as describes above, FALSE otherwise.

 

Sample Input

 

rbgggrrggbgr
rrrbbbrrbbbr
rbgrbgrrrrrg

 

Sample Output

 

TRUE
FALSE
FALSE


题意很简单,就是判断两个骰子是否相同。
分析:分析可知1-6,2-5,3-4,所以两个骰子若相同的话,必定面对面的花色是一样的,所以只要判断两个骰子的所形成的三个对面是否都能够对应起来就可以了
#include<stdio.h>
#include<string.h>

int main()
{
    char str[20];
    int hash1[130][130],hash2[130][130];
    int i;
    while(scanf("%s",str)!=EOF)
    {
        memset(hash1,0,sizeof(hash1));
        memset(hash2,0,sizeof(hash2));
        for(i=0;i<=2;i++)
        {
            hash1[str[i]][str[5-i]]++;
            hash1[str[5-i]][str[i]]++;
        }
        for(i=6;i<9;i++)
        {
             hash2[str[i]][str[17-i]]++;
             hash2[str[17-i]][str[i]]++;
        }
        for(i=0;i<=2;i++)
        {
            if(hash1[str[i]][str[5-i]]!=hash2[str[i]][str[5-i]]) break;
        }
        if(i==3) printf("TRUE\n");
        else printf("FALSE\n");
    }
    return 0;
}

转载于:https://www.cnblogs.com/zsboy/archive/2012/08/27/2659066.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值