poj 2386 lake counting

16 篇文章 0 订阅

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3


#include<cstdio>
#include <iostream>
#include<cstring>
using namespace std;
char map[101][101];///一直开了50那么大,都是不好好读题的结果!!!

/*const int dx[4] = {0,0,-1,1};
const int dy[4] = {-1,1,0,0};*/
int r, c;
void dfs(int x,int y)
{
    map[x][y] = '.';
    /*if(x>=r || x<0)
        return;
    if(y>=c || y<0)
        return;*没什么用,因为前面已经限制过了
    int x_new,y_new;
    /*for(int i=0; i<4; i++)
    {

        x_new = x + dx[i];
        y_new = y + dy[i];
        if(x_new>=0 && x_new<r && y_new>=0 && y_new<c && map[x_new][y_new] == 'W')
        {
           dfs(x_new,y_new);
        }

    }*这样写的话,缺少(-1,-1),(1,1),(-1,1),(1,-1)这四种情况
    for(int dx=-1; dx<=1; dx++)
    {
        for(int dy = -1; dy<=1; dy++)
        {
            x_new = x + dx;
            y_new = y + dy;
            if(x_new>=0 && x_new<r && y_new>=0 && y_new<c && map[x_new][y_new] == 'W')
            {
                dfs(x_new,y_new);
            }

        }

    }
    return;
}
int main()
{
    int cnt = 0;
    scanf("%d%d",&r, &c);
    /*for(int i=0; i<r; i++)
    {
        for(int j=0; j<c; j++)
        {
            scanf("%c", &map[i][j]);
            if(map[i][j] == 'W')
            {
                dfs(i,j);
                cnt++;
            }
        }
    }*刚开始时一直这么写,导致结果不对。
    for(int i=0; i<r; i++)
        scanf("%s", map[i]);
    for(int i=0; i<r; i++)
    {
        for(int j=0; j<c; j++)
        {

            if(map[i][j] == 'W')
            {
                dfs(i,j);
                cnt++;
            }
        }
    }
    printf("%d\n",cnt);
    return 0;
}
这道题做得太不容易了,老是想错。
竟然有点怀疑poj了,真傻,出错的只会是自己啊!!!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
题目描述: 给定一个 $N \times M$ 的矩阵,其中 "." 表示水洼,"W" 表示水。请计算有多少个水洼。 解题思路: 这是一道非常经典的搜索题目。我们可以使用 DFS 或 BFS 进行求解。 首先,我们需要遍历整个矩阵,当我们遇到一个 "." 时,我们就从该点开始向四周搜索,将所有相邻的 "." 变为 "W" ,并继续向下搜索。每次搜索完毕后,我们就可以找到一个完整的水洼,计数器加一。最后,当我们遍历完整个矩阵后,就可以得到所有的水洼数量。 代码实现: 使用 DFS 进行搜索: ```c++ #include <iostream> using namespace std; const int maxn = 110; char field[maxn][maxn]; bool vis[maxn][maxn]; int n, m; void dfs(int x, int y) { vis[x][y] = true; for (int dx = -1; dx <= 1; dx++) { for (int dy = -1; dy <= 1; dy++) { int nx = x + dx, ny = y + dy; if (nx >= 0 && nx < n && ny >= 0 && ny < m && !vis[nx][ny] && field[nx][ny] == '.') { dfs(nx, ny); } } } } int main() { cin >> n >> m; for (int i = 0; i < n; i++) { for (int j = 0; j < m; j++) { cin >> field[i][j]; } } int res = 0; for (int i = 0; i < n; i++) { for (int j = 0; j < m; j++) { if (!vis[i][j] && field[i][j] == '.') { dfs(i, j); res++; } } } cout << res << endl; return 0; } ``` 使用 BFS 进行搜索: ```c++ #include <iostream> #include <queue> using namespace std; const int maxn = 110; char field[maxn][maxn]; bool vis[maxn][maxn]; int n, m; void bfs(int x, int y) { queue<pair<int, int>> q; q.push(make_pair(x, y)); vis[x][y] = true; while (!q.empty()) { int cx = q.front().first, cy = q.front().second; q.pop(); for (int dx = -1; dx <= 1; dx++) { for (int dy = -1; dy <= 1; dy++) { int nx = cx + dx, ny = cy + dy; if (nx >= 0 && nx < n && ny >= 0 && ny < m && !vis[nx][ny] && field[nx][ny] == '.') { q.push(make_pair(nx, ny)); vis[nx][ny] = true; } } } } } int main() { cin >> n >> m; for (int i = 0; i < n; i++) { for (int j = 0; j < m; j++) { cin >> field[i][j]; } } int res = 0; for (int i = 0; i < n; i++) { for (int j = 0; j < m; j++) { if (!vis[i][j] && field[i][j] == '.') { bfs(i, j); res++; } } } cout << res << endl; return 0; } ``` 时间复杂度: 两种方法的时间复杂度均为 $O(NM)$,其中 N 和 M 分别为矩阵的行数和列数。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值