【POJ 2386】 Lake Counting

Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1N100;1M100)  squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2..N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output

  • Line 1: The number of ponds in Farmer John’s field.

Sample Input

引用块内容

Sample Output

3

解题思路

给定一张有积水的图,判断形成几个水塘。
每个“w”是8连通的,连在一起的“w”算一个pond。可以用DFS来搜索与当前的“W”连通的所有“W”,并把搜索过的做标记,防止二次搜索。
最终搜索的次数就是形成的pond的个数。

参考代码

#include <stdio.h>
const int maxn = 110;
char field[maxn][maxn]={0};
int n,m;
void DFS(int x,int y){
    field[x][y] = '.';//搜索过的做标记
    for (int dx = -1;dx <= 1;dx++)
        for (int dy = -1;dy <= 1;dy++){//八方向搜索
            int nx = x +dx,ny = y +dy;
            if (field[nx][ny] == 'W')
                DFS(nx,ny);
        }
}
int main()
{
    scanf("%d%d",&n,&m);
    getchar();
    for (int i = 1;i <= n;i++){
        for (int j = 1;j <= m;j++)
            field[i][j] = getchar();
        getchar();
    }
    int ans = 0;
    for (int i = 1;i <= n;i++)
        for (int j = 1;j <= m;j++)
            if (field[i][j] == 'W'){
                DFS(i,j);
                ans ++;
            }
    printf("%d\n",ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值