ERROR: In F:\PCLdon\VTK-7.0.0\Rendering\OpenGL2\vtkOpenGLRenderWindow.cxx, line 545 vtkWin32OpenGLRe

ERROR: In F:\PCLdon\VTK-7.0.0\Rendering\OpenGL2\vtkOpenGLRenderWindow.cxx, line 545
vtkWin32OpenGLRenderWindow (0000000002A3F020): GL version 2.1 with the gpu_shader4 extension is not supported by your graphics driver but is required for the new OpenGL rendering backend. Please update your OpenGL driver. If you are using Mesa please make sure you have version 10.6.5 or later and make sure your driver in Mesa supports OpenGL 3.2.

ERROR: In F:\PCLdon\VTK-7.0.0\Rendering\OpenGL2\vtkOpenGLRenderWindow.cxx, line 545
vtkWin32OpenGLRenderWindow (0000000002A3F020): GL version 2.1 with the gpu_shader4 extension is not supported by your graphics driver but is required for the new OpenGL rendering backend. Please update your OpenGL driver. If you are using Mesa please make sure you have version 10.6.5 or later and make sure your driver in Mesa supports OpenGL 3.2.

ERROR: In F:\PCLdon\VTK-7.0.0\Rendering\OpenGL2\vtkShaderProgram.cxx, line 369
vtkShaderProgram (00000000035E7160): 1: #version 120
2: #extension GL_EXT_gpu_shader4 : require
3: #define highp
4: #define mediump
5: #define lowp
6:
7: /*=========================================================================
8:
9:   Program:   Visualization Toolkit
10:   Module:    vtkPolyDataFS.glsl
11:
12:   Copyright (c) Ken Martin, Will Schroeder, Bill Lorensen
13:   All rights reserved.
14:   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
15:
16:      This software is distributed WITHOUT ANY WARRANTY; without even
17:      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
18:      PURPOSE.  See the above copyright notice for more information.
19:
20: =========================================================================*/
21: // Template for the polydata mappers fragment shader
22:
23: uniform int PrimitiveIDOffset;
24:
25: // VC position of this fragment
26: //VTK::PositionVC::Dec
27:
28: // optional color passed in from the vertex shader, vertexColor
29: uniform float opacityUniform; // the fragment opacity
30: uniform vec3 ambientColorUniform; // intensity weighted color
31: uniform vec3 diffuseColorUniform; // intensity weighted color
32: varying vec4 vertexColorVSOutput;
33:
34:
35: // optional surface normal declaration
36: //VTK::Normal::Dec
37:
38: // extra lighting parameters
39: //VTK::Light::Dec
40:
41: // Texture coordinates
42: //VTK::TCoord::Dec
43:
44: // picking support
45: //VTK::Picking::Dec
46:
47: // Depth Peeling Support
48: //VTK::DepthPeeling::Dec
49:
50: // clipping plane vars
51: //VTK::Clip::Dec
52:
53: // the output of this shader
54: //VTK::Output::Dec
55:
56: // Apple Bug
57: //VTK::PrimID::Dec
58:
59: // handle coincident offsets
60: //VTK::Coincident::Dec
61:
62: void main()
63: {
64:   // Apple Bug
65:   //VTK::PrimID::Impl
66:
67:   //VTK::Clip::Impl
68:
69:   vec3 ambientColor;
70:   vec3 diffuseColor;
71:   float opacity;
72:   ambientColor = ambientColorUniform;
73:   diffuseColor = diffuseColorUniform;
74:   opacity = opacityUniform;
75:   diffuseColor = vertexColorVSOutput.rgb;
76:   opacity = opacity*vertexColorVSOutput.a;
77:
78:   // VC position of this fragment
79:   //VTK::PositionVC::Impl
80:
81:   // Generate the normal if we are not passed in one
82:   //VTK::Normal::Impl
83:
84:     gl_FragData[0] = vec4(ambientColor + diffuseColor, opacity);
85:   //VTK::Light::Impl
86:
87:
88:   //VTK::TCoord::Impl
89:
90:   if (gl_FragData[0].a <= 0.0)
91:     {
92:     discard;
93:     }
94:
95:   //VTK::DepthPeeling::Impl
96:
97:   //VTK::Picking::Impl
98:
99:   // handle coincident offsets
100:   //VTK::Coincident::Impl
101: }
102:


ERROR: In F:\PCLdon\VTK-7.0.0\Rendering\OpenGL2\vtkShaderProgram.cxx, line 370

vtkShaderProgram (00000000035E7160): ERROR: 0:2: '' :  extension 'GL_EXT_gpu_shader4' is not supported



这是由于VTK只支持英伟达的显卡。

1.如果出现这种问题,首先确保你有独立显卡(英伟达的)。

2.找开显卡设置面板,将全局设置那一栏下的首先图形处理器设为高性能NVDIA处理器。

阅读终点,创作起航,您可以撰写心得或摘录文章要点写篇博文。去创作
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bai_Dreamer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值