One-by-one to solve the Sequence Problem (1)

One-by-one to solve the Sequence Problem (1)

1400 : Composition (from hihocoder)

时间限制:10000ms
单点时限:1000ms
内存限制:256MB
描述
Alice writes an English composition with a length of N characters. However, her teacher requires that M illegal pairs of characters cannot be adjacent, and if ‘ab’ cannot be adjacent, ‘ba’ cannot be adjacent either.
In order to meet the requirements, Alice needs to delete some characters.
Please work out the minimum number of characters that need to be deleted.
输入
The first line contains the length of the composition N.
The second line contains N characters, which make up the composition. Each character belongs to ‘a’..’z’.
The third line contains the number of illegal pairs M.
Each of the next M lines contains two characters ch1 and ch2,which cannot be adjacent.
For 20% of the data: 1 ≤ N ≤ 10
For 50% of the data: 1 ≤ N ≤ 1000
For 100% of the data: 1 ≤ N ≤ 100000, M ≤ 200.
输出
One line with an integer indicating the minimum number of characters that need to be deleted.

样例提示
Delete ‘a’ and ‘d’.

样例输入

5
abcde
3
ac
ab
de

样例输出

2

Code

#include <iostream>
#include <list>
#include <vector>
#include <string>
#include <unordered_map>
#include <unordered_set>
#include <utility>
using namespace std;
typedef unsigned int unint;
typedef unordered_set<string> setstr;
typedef unordered_map<char, unint> mapchar;
typedef pair<char, unint> pcu;
int main() {
    int N = 0;
    while (cin >> N) {
        string ts;
        cin >> ts;
        list<char> mstr(ts.begin(), ts.end());
        int m = 0;
        cin >> m;
        setstr mp;
        for (int i = 0; i < m; ++i)
        {
            string s1;
            cin >> s1;
            mp.insert(s1);
            char tc = s1[0];
            s1[0] = s1[1];
            s1[1] = tc;
            mp.insert(s1);

        }
        mapchar mmp;
        mmp.insert(pair<char,unint>(ts[0], 0));
        for (int i =1;i<N; ++i) {
            char c = ts[i];
            mapchar tmmp;
            string s11(2,'0');
            auto resf0 = mmp.find(c);
            tmmp.insert(pcu(c, i));
            s11[1] = c;
            for (auto it : mmp) {
                // delete
                it.second += 1;
                auto resf = tmmp.find(it.first);
                if (resf == tmmp.end()) {
                    tmmp.insert(it);
                }
                else {
                    if (resf->second > it.second)
                        resf->second = it.second;
                }
                // keep it
                it.second -= 1;
                s11[0] = it.first;
                auto resf1 = mp.find(s11);
                if (resf1 == mp.end()) {
                    // insert it
                    auto resf11 = tmmp.find(c);
                    if (resf11 == tmmp.end()) 
                    {
                        tmmp.insert(pcu(c, it.second));
                    }
                    else {
                        if (resf11->second > it.second)
                            resf11->second = it.second;
                    }
                }
            }// for it : mmp
            mmp = tmmp;
        }
        unint res1 = 0x0fffffff;
        for (auto i : mmp) {
            if (res1 > i.second)
                res1 = i.second;
        }
        cout << res1 << endl;
    }// end of while
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值