HDU 5763 Another Meaning(KMP+DP)

<span style="font-family: Arial, Helvetica, sans-serif;"></span>

Problem Description
As is known to all, in many cases, a word has two meanings. Such as “hehe”, which not only means “hehe”, but also means “excuse me”.
Today, ?? is chating with MeiZi online, MeiZi sends a sentence A to ??. ?? is so smart that he knows the word B in the sentence has two meanings. He wants to know how many kinds of meanings MeiZi can express.


Input
The first line of the input gives the number of test cases T; T test cases follow.
Each test case contains two strings A and B, A means the sentence MeiZi sends to ??, B means the word B which has two menaings. string only contains lowercase letters.

Limits
T <= 30
|A| <= 100000
|B| <= |A|



Output
For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the number of the different meaning of this sentence may be. Since this number may be quite large, you should output the answer modulo 1000000007.


Sample Input
4
hehehe
hehe
woquxizaolehehe
woquxizaole
hehehehe
hehe
owoadiuhzgneninougur
iehiehieh


Sample Output
Case #1: 3
Case #2: 2
Case #3: 5
Case #4: 1

Hint
In the first case, “ hehehe” can have 3 meaings: “*he”, “he*”, “hehehe”.
In the third case, “hehehehe” can have 5 meaings: “*hehe”, “he*he”, “hehe*”, “**”, “hehehehe”.


题意:给两个字符串A,B。B如果与A中的子串相同则可以替换,替换后意思会发生改变,问最多有多少种意思。

如:A="hehehehe",B="hehe"。由B替换的位置用*表示,则替换后的情况有:“*hehe”, “he*he”, “hehe*”, “**”, “hehehehe”.(可以不替换)
思路:先用KMP预处理,vis[i]表示以i位置开始的A的子串是否与B相同。设n,m为A,B串长度。
dp[i]表示A串0~i+m-1位置有多少种意思。如果vis[i]==0,则i位置的子串不能替换,dp[i]=dp[i-1];如果vis[i]==1,如果替换i位置,则有dp[i-m]+1种意思,如果不替换i位置,则有dp[i-1]种,所以此时dp[i]=dp[i-1]+dp[i-m]+1。要特判一下i-1,i-m越界的情况。

<span style="font-family: Arial, Helvetica, sans-serif;"></span>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <string>
using namespace std;

char a[100005],b[100005];
int f[100005];
const long long mod = (long long)1000000007;
bool vis[100005];
long long dp[100005];

long long power(long long a,long long p)
{
    long long ans=1;
    while(p)
    {
        if(p&1)
            ans=(ans*a)%mod;
        a=(a*a)%mod;
        p>>=1;
    }
    return ans;
}

int main()
{
    int cas=1;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        scanf("%s%s",a,b);
        int n=(int)strlen(a);
        int m=(int)strlen(b);
        memset (f, 0, sizeof(f)); 
        for (int i =1; i < m; i++)
        {
            int j = f[i];
            while( j && b[i] != b[j])
                j=f[j];
            f[i + 1] = (b[i] == b[j]) ? j+1 : 0;
        }
        int j = 0;
        for (int i = 0; i < n; i++)
        {
            while(j && a[i]!=b[j])
                j=f[j];
            if(a[i]==b[j])    j++;
            if(j==m)
            {
                vis[i-m+1]=1;
            }
        }
        memset(dp,0,sizeof(dp));
        for(int i=0;i<=n-m;i++)
        {
            if(vis[i]==1)
            {
                if(i-m<0&&i-1<0)
                {
                    dp[i]=1;
                }
                else if(i-m<0&&i-1>=0)
                {
                    dp[i]=(dp[i-1]+1)%mod;
                }
                else
                {
                    dp[i]=(dp[i-m]+dp[i-1]+1)%mod;
                }
            }
            else dp[i]=dp[i-1];
            //cout<<i<<"~"<<dp[i]<<endl;
        }
        printf("Case #%d: %I64d\n",cas++,(dp[n-m]+1)%mod);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值