POJ_3281_Dining

Dining
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12800 Accepted: 5866

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers:  NF, and  D 
Lines 2.. N+1: Each line  i starts with a two integers  Fi and  Di, the number of dishes that cow  i likes and the number of drinks that cow  i likes. The next  Fi integers denote the dishes that cow  i will eat, and the  Di integers following that denote the drinks that cow  i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint

One way to satisfy three cows is: 
Cow 1: no meal 
Cow 2: Food #2, Drink #2 
Cow 3: Food #1, Drink #1 
Cow 4: Food #3, Drink #3 
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

Source



网络流水题

问题为给出n头牛喜欢吃的和喝的

然后问可以有多少牛有吃有喝

经典处理方法把一头牛牛拆成两个点

两点间流量为1即控制了每头牛只有一种选择

两点一边连吃一边连喝即可


#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;

const int M=500;         //最大点数
const int IN=1e9;        //流无限值
int g[M][M],np,p[M];
//  g图的邻接表,np点数,p前驱结点数组
int ekst,eked;        //源与汇
bool EK_bfs()
{
    queue<int> qu;
    bool f[M];
    memset(f,0,sizeof(f));
    memset(p,-1,sizeof(p));
    qu.push(ekst);
    f[ekst]=1;
    while(!qu.empty())
    {
        int e=qu.front();
        if(e==eked)             //找到增广路
            return 1;
        qu.pop();
        for(int i=1;i<=np;i++)
        {
            if(g[e][i]&&!f[i])
            {
                f[i]=1;
                p[i]=e;
                qu.push(i);
            }
        }
    }
    return 0;
}
int EKA()           //Edmond_Karp_Algorithm
                    //会改图,最终剩下流量残图
{
    int u,mf=0,mn;
    //u为当前结点,mf最终答案,mn目前增广路的最大流
    while(EK_bfs())
    {
        mn=IN;
        u=eked;
        while(p[u]!=-1)//找瓶颈流量
        {
            mn=min(mn,g[p[u]][u]);
            //cout<<mn;
            u=p[u];
        }
        mf+=mn;
        u=eked;
        while(p[u]!=-1)
        {
            g[p[u]][u]-=mn;//删去瓶颈流量
            g[u][p[u]]+=mn;//建立反向边
            u=p[u];
        }
    }
    return mf;
}

int main()
{
    int N,F,D;
    scanf("%d%d%d",&N,&F,&D);
    ekst=0;eked=2*N+F+D+1;np=2*N+F+D+1;
    for(int i=1;i<=N;i++)   //同一头牛
        g[i][i+N]=1;
    for(int i=1;i<=F;i++)   //食物
        g[ekst][i+2*N]=1;
    for(int i=1;i<=D;i++)   //食物
        g[i+2*N+F][eked]=1;
    for(int i=1;i<=N;i++)
    {
        int fi,di,ff,dd;
        scanf("%d%d",&fi,&di);
        for(int j=1;j<=fi;j++)
        {
            scanf("%d",&ff);
            g[ff+2*N][i]=1;
        }
        for(int j=1;j<=di;j++)
        {
            scanf("%d",&dd);
            g[i+N][dd+2*N+F]=1;
        }
    }
    //cout<<"1"<<endl;
    printf("%d\n",EKA());
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值