hdu 5783 Divide the Sequence【水题】

Divide the Sequence

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 126    Accepted Submission(s): 79


Problem Description
Alice has a sequence A, She wants to split A into as much as possible continuous subsequences, satisfying that for each subsequence, every its prefix sum is not small than 0.
 

Input
The input consists of multiple test cases.
Each test case begin with an integer n in a single line.
The next line contains n integers A1,A2An .
1n1e6
10000A[i]10000
You can assume that there is at least one solution.
 

Output
For each test case, output an integer indicates the maximum number of sequence division.
 

Sample Input
6
1 2 3 4 5 6
1 2 -3 0
5
0 0 0 0 0
 

Sample Output
6
2
5

Author
ZSTU
Source


题目大意:将一个序列拆分成尽可能多的子序列,使得子序列的前缀和全部大于等于0、


思路:


1、正向考虑,找到一个负数之后,从后向前找,直到加和为0为止,这个区间就是一个子序列。如果没有负数,其他的各自成一个序列。可惜会TLE 。因为时间复杂度不定,最不好的情况甚至会达到N^2。


2、那么我们不妨逆向思维来想这个问题,倒着走,如果遇到了一个负数之后,继续向前走,直到加和为0为止,这个区间就是一个子序列,如果没有负数,其他的各自成一个序列。


Ac代码:


#include<stdio.h>
#include<string.h>
using namespace std;
#define ll __int64
ll a[1000500];
ll aa[10005000];
ll sum[1000500];
int main()
{
    ll n;
    while(~scanf("%I64d",&n))
    {
        memset(sum,0,sizeof(sum));
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++)
        {
            scanf("%I64d",&a[i]);
        }
        int output=n;
        int tmp=0;
        ll summ;
        for(int i=n-1;i>=0;i--)
        {
            if(tmp==0&&a[i]>=0)continue;
            if(tmp==0&&a[i]<0)
            {
                tmp=1;
                summ=a[i];
                continue;
            }
            if(tmp==1)
            {
                summ+=a[i];
                output--;
                if(summ>=0)
                {
                    tmp=0;
                }
            }
        }
        printf("%d\n",output);
    }
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值