HDU 5783 Divide the Sequence 思维题

题目描述:

Problem Description
Alice has a sequence A, She wants to split A into as much as possible continuous subsequences, satisfying that for each subsequence, every its prefix sum is not small than 0.

Input
The input consists of multiple test cases.
Each test case begin with an integer n in a single line.
The next line contains n integers A1,A2⋯An.
1≤n≤1e6
−10000≤A[i]≤10000
You can assume that there is at least one solution.

Output
For each test case, output an integer indicates the maximum number of sequence division.

Sample Input

6
1 2 3 4 5 6
4
1 2 -3 0
5
0 0 0 0 0

Sample Output

6
2
5

题目分析:

2016HDU多校第五场1003。
大意是给一个序列,让你分割这个序列,使得所有被分割后的子序列的前缀和都不小于零。
开始的时候不知道该怎么分析,从前往后推发现时间不允许O(n^2)的复杂度。
其实,只要从后往前贪心,将标记从前往后找的状态(小于零需要前缀来),往前找到和大于等于零位为止。其实还是要看你的思维是否灵活。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>

const int maxn=1e6+10;
using namespace std;
typedef long long LL;

LL n;
LL a[maxn];
int main()
{
    while(scanf("%I64d",&n)!=-1)
    {
        for(LL i=1; i<=n; i++)
        {
            scanf("%I64d",&a[i]);
        }
        LL count=0;
        LL tmp=0;
        for(LL i=n; i>=1; i--)
        {
            if (a[i]>=0)
            {
                if (tmp==0) count++;
                else
                {
                    if (a[i]+tmp>=0) {count++;tmp=0;}
                    else tmp+=a[i];
                }
            }
            else tmp+=a[i];
        }
        printf("%I64d\n",count);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值