hdoj5783Divide the Sequence

54 篇文章 0 订阅

Divide the Sequence

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 501    Accepted Submission(s): 275


Problem Description
Alice has a sequence A, She wants to split A into as much as possible continuous subsequences, satisfying that for each subsequence, every its prefix sum is not small than 0.
 

Input
The input consists of multiple test cases. 
Each test case begin with an integer n in a single line.
The next line contains  n  integers  A1,A2An .
1n1e6
10000A[i]10000
You can assume that there is at least one solution.
 

Output
For each test case, output an integer indicates the maximum number of sequence division.
 

Sample Input
  
  
6 1 2 3 4 5 6 4 1 2 -3 0 5 0 0 0 0 0
 

Sample Output
  
  
6 2 5
 

Author
ZSTU
 

Source
 

/* ***********************************************
Author       : ryc
Created Time : 2016-08-03 Wednesday
File Name    : E:\acmcode\hdoj\5783.cpp
LANGUAGE     : c++
Copyright 2016 ryc All Rights Reserved
************************************************ */
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<map>
using namespace std;
const int maxn=1000010;
long long num[maxn];
long long sum[maxn];
long long pos[maxn];
bool sign[maxn];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        for(int i=1;i<=n;++i){
            scanf("%lld",&num[i]);
            sum[i]=sum[i-1]+num[i];
        }
        memset(sign,false,sizeof(sign));
        long long ans=0,temp=0,l=1;pos[0]=-1;
        for(int i=1;i<=n;++i){
            temp+=num[i];
            while(temp<0&&l>0){
                l=pos[l-1];
                temp=sum[i]-sum[l-1];sign[l]=false;
            }
            sign[l]=true;pos[i]=l;l=i+1;temp=0;
        }
        for(int i=1;i<=n;++i){
            if(sign[i])ans++;
        }
        printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值