1051. Pop Sequence (25)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES

NO


IDEA

1.用栈进行模拟

2.maxnum初始化为m,栈的容量,若遇到目标值大于当前maxnum,则是非法的

3.当栈为空,或者栈不空且栈顶元素不等于目标值且应该入栈的元素不大于n且栈中元素个数不大于栈容量时,num进栈


CODE

#include<iostream>
#include<vector>
#include<stack>
#include<fstream>
using namespace std;
int main(){
	freopen("input.txt","r",stdin);
	int m,n,k;
	cin>>m>>n>>k;
	while(k--){
		int flag=1;
		vector<int> vec(n);
		for(int i=0;i<n;i++){
			cin>>vec[i];
		}
		stack<int> sta;
		int maxnum=m;
		int num=1;
		for(int i=0;i<n;i++){
			if(vec[i]>maxnum){
				cout<<"NO"<<endl;
				flag=0;
				break;
			}
			
			while ((sta.empty()||(!sta.empty()&&sta.top()!=vec[i]))&&num<=n&&sta.size()<=m){
				sta.push(num++);
			}
			if(sta.top()!=vec[i]){
				cout<<"NO"<<endl;
				flag=0;
				break;
			}
			sta.pop();
			maxnum++;
		}
		if(flag){
			cout<<"YES"<<endl;
		}
	}
	
	fclose(stdin);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值